Dzisiaj jest 4 gru 2022, 14:15

Strefa czasowa UTC+1godz. [letni]




Nowy temat Odpowiedz w temacie  [ Posty: 6 ] 
Autor Wiadomość
 Tytuł: IPv6 i ds-lite Neostrada Orange VDSL
Post: 9 paź 2022, 19:37 
Offline
Użytkownik

Rejestracja: 28 wrz 2010, 21:44
Posty: 59
Witam
Nie moge dojsc w jaki sposob ustawic IPv6 pod orange neostrada

/etc/config/network
config interface 'WAN'
        option proto 'pppoe'
        option device 'lan4.9'
        option username 'login@neostrada.pl/ipv6'
        option password 'haslo'
        option mtu '1500'
        option ipv6 '1'

config device
        option name 'pppoe-WAN'
        option type 'tunnel'

config interface 'WAN6'
        option proto 'dhcpv6'
        option device 'pppoe-WAN'
        option reqaddress 'try'
        option reqprefix 'auto'
        option ip6assign '56'


/etc/config/dhcp
config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option dhcpv4 'server'
        option limit '100'
        option leasetime '13h'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option dhcpv6 'server'
        option ra_default '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'



Router sam zestawia IPv6 i interface ds-lite . IPv4 dziala jak należy
IPv6 dziala na routerze i tylko tam:
root@router:~# ping6 -c3 ipv6.google.com
PING ipv6.google.com (2a00:1450:401b:808::200e): 56 data bytes
64 bytes from 2a00:1450:401b:808::200e: seq=0 ttl=119 time=23.157 ms


Co robię źle ?


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: IPv6 i ds-lite Neostrada Orange VDSL
Post: 9 paź 2022, 20:02 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 14095
Lokalizacja: Warszawa
Dodałeś WAN6 do sekcji wan firewalla?

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: IPv6 i ds-lite Neostrada Orange VDSL
Post: 9 paź 2022, 21:02 
Offline
Użytkownik

Rejestracja: 28 wrz 2010, 21:44
Posty: 59
obsy pisze:
Dodałeś WAN6 do sekcji wan firewalla?

tak oczywiscie ,routing i dns dziala ale tylko na routerze


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: IPv6 i ds-lite Neostrada Orange VDSL
Post: 10 paź 2022, 11:01 
Offline
Użytkownik

Rejestracja: 28 wrz 2010, 21:44
Posty: 59
wiecej logow

root@mr1800x:~# ifstatus WAN
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 1094,
        "l3_device": "pppoe-WAN",
        "proto": "pppoe",
        "device": "lan4.9",
        "updated": [
                "addresses"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": false,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "fe80::4c58:d7ba:8e71:324f",
                        "mask": 128
                }
        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [

        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}
root@mr1800x:~# ifstatus WAN6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 1164,
        "l3_device": "pppoe-WAN",
        "proto": "dhcpv6",
        "device": "pppoe-WAN",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [

        ],
        "ipv6-prefix": [
                {
                        "address": "2a01:117f:45a:7c00::",
                        "mask": 56,
                        "preferred": 85236,
                        "valid": 85236,
                        "class": "WAN6",
                        "assigned": {
                                "WAN6": {
                                        "address": "2a01:117f:45a:7c00::",
                                        "mask": 56
                                }
                        }
                }
        ],
        "ipv6-prefix-assignment": [
                {
                        "address": "2a01:117f:45a:7c00::",
                        "mask": 56,
                        "preferred": 85236,
                        "valid": 85236,
                        "local-address": {
                                "address": "2a01:117f:45a:7c00::1",
                                "mask": 56
                        }
                },
                {
                        "address": "fd6d:54ca:77bf::",
                        "mask": 56,
                        "local-address": {
                                "address": "fd6d:54ca:77bf::1",
                                "mask": 56
                        }
                }
        ],
        "route": [
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::cee1:7fff:fe05:d3c3",
                        "metric": 512,
                        "valid": 666,
                        "source": "2a01:117f:45a:7c00::/56"
                }
        ],
        "dns-server": [
                "2a01:1700:2:ffff::9f01",
                "2a01:1700:3:ffff::9822"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {
                "passthru": "001700202a0117000002ffff0000000000009f012a0117000003ffff0000000000009822"
        }
}


Windows adapter wyglada jak ponizej . Co robi tam %21 ?
Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . : lan
   IPv6 Address. . . . . . . . . . . : fd6d:54ca:77bf:100::8b7
   IPv6 Address. . . . . . . . . . . : fd6d:54ca:77bf:100:b894:a24a:a935:3fb4
   Temporary IPv6 Address. . . . . . : fd6d:54ca:77bf:100:55c6:1fe1:e5bd:27a
   Link-local IPv6 Address . . . . . : fe80::b894:a24a:a935:3fb4%21
   IPv4 Address. . . . . . . . . . . : 192.168.1.103
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : fe80::e25:2fff:fe7f:f1de%21
                                       192.168.1.2


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: IPv6 i ds-lite Neostrada Orange VDSL
Post: 21 paź 2022, 22:31 
Offline
Użytkownik

Rejestracja: 21 paź 2022, 22:19
Posty: 1
Moim zdaniem musisz wyrzucić z sekcji WAN6 linię:
option ip6assign '56'
(domyślnie powinno być disabled)
Interfejs WAN6 ma dostać adres z innego zakresu niż delegowany prefix. Prefix jest do podziału na lan, guest i co tam jeszcze wymyślisz. Dla nich suma "IPv6 assignment length" nie może przekroczyć zakresu PD z góry (tutaj 56, tyle chyba dostajesz przy reqprefix=auto, tak?).
Windows dostaje adres IPv6 lokalny, ale wyczerpałeś PD w całości na WAN6 i zabrakło przydziału zakresu globalnego na lan.


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: IPv6 i ds-lite Neostrada Orange VDSL
Post: 25 paź 2022, 15:20 
Offline
Użytkownik

Rejestracja: 28 wrz 2010, 21:44
Posty: 59
z takim konfigiem juz dziala .

/etc/config/dhcp dodana konfiguracja ipv6 server
config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option dhcpv4 'server'
        option limit '100'
        option leasetime '1h'
        option ra 'server'
        option ra_default '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option dhcpv6 'server'
        option ndp 'hybrid'


/etc/config/network dodanie prefixu i ip6hint
config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.2'
        option ip6assign '60'
        option ip6hint 10

config interface 'WAN6'
        option proto 'dhcpv6'
        option device 'pppoe-WAN'
        option reqaddress 'try'
        option reqprefix 'auto'


/etc/config/firewall dodane wpisy
config rule
        option name 'Allow-DHCPv6-546'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'
        option src_port '547'

config rule
        option name 'Allow-DHCPv6-547'
        option src 'wan'
        option proto 'udp'
        option dest_port '547'
        option family 'ipv6'
        option target 'ACCEPT'
        option src_port '546'


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat Odpowiedz w temacie  [ Posty: 6 ] 

Strefa czasowa UTC+1godz. [letni]


Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 47 gości


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów

Szukaj:
Przejdź do:  
designed by digi-led.pl
...Copyright © 2010-2013, Ekipa openrouter.info