Dzisiaj jest 27 paź 2021, 06:02

Strefa czasowa UTC+1godz. [letni]




Nowy temat Odpowiedz w temacie  [ Posty: 2037 ]  Przejdź na stronę Poprzednia  1 ... 98, 99, 100, 101, 102
Autor Wiadomość
 Tytuł: Re: ZyXEL NSA310
Post: 9 cze 2020, 18:56 
Offline
Użytkownik

Rejestracja: 10 lip 2015, 08:06
Posty: 41
kwboota masz jako kwboot.tar.gz? Jezeli tak to (w terminalu linuxa):

tar -zxvf kwboot.tar.gz
cd /kwboot
make


potem wrzucasz plik uboota do katalogu z kwbootem i

sudo ./kwboot -t -p -B 115200 /dev/ttyUSB0 -b nazwa_twojego_pliku_uboota.kwb


Robisz to na wylacoznym nasie, potem masz info zeby go wlaczyc i uboot powinien sie ladowac (leca procenty)


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 9 cze 2020, 18:58 
Offline
Użytkownik

Rejestracja: 29 maja 2020, 19:17
Posty: 24
samo kwboot
czy mam dopisać resztę w nazwie pliku?


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 9 cze 2020, 19:02 
Offline
Użytkownik

Rejestracja: 29 maja 2020, 19:17
Posty: 24
i jeszcze czy w konsoli nie muszę ścieżki jakoś podać?


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 9 cze 2020, 19:29 
Offline
Użytkownik

Rejestracja: 29 maja 2020, 19:17
Posty: 24
plik kwboot był dołączony z plikiem kwboot 1 po otwarciu go w linuksie:
.TH KWBOOT 1 "2012-05-02"

.SH NAME
kwboot \- Boot Marvell Kirkwood SoCs over a serial link.
.SH SYNOPSIS
.B kwboot
.RB [ "-b \fIimage\fP" ]
.RB [ "-p" ]
.RB [ "-t" ]
.RB [ "-B \fIbaudrate\fP" ]
.RB [\fITTY\fP]
.SH "DESCRIPTION"

The
.B kwboot
program boots boards based on Marvell's Kirkwood platform over their integrated
UART. Boot image files will typically contain a second stage boot loader, such
as U-Boot. The image file must conform to Marvell's BootROM firmware image
format (\fIkwbimage\fP), created using a tool such as .B mkimage.

Following power-up or a system reset, system BootROM code polls the UART for a
brief period of time, sensing a handshake message which initiates an image
upload. This program sends this boot message until it receives a positive
acknowledgement. The image is transfered using Xmodem.

Additionally, this program implements a minimal terminal mode, which can be
used either standalone, or entered immediately following boot image transfer
completion. This is often useful to catch early boot messages, or to manually
interrupt a default boot procedure performed by the second-stage loader.

.SH "OPTIONS"

.TP
.BI "\-b \fIimage\fP"
Handshake; then upload file \fIimage\fP over \fITTY\fP.

Note that for the encapsulated boot code to be executed, \fIimage\fP must be of
type "UART boot" (0x69). Boot images of different types, such as backup images
of vendor firmware downloaded from flash memory (type 0x8B), will not work (or
not as expected). See \fB-p\fP for a workaround.

This mode writes handshake status and upload progress indication to stdout.

.TP
.BI "\-p"
In combination with \fB-b\fP, patches the header in \fIimage\fP prior to
upload, to "UART boot" type.

This option attempts on-the-fly conversion of some none-UART image types, such
as images which were originally formatted to be stored in flash memory.

Conversion is performed in memory. The contents of \fIimage\fP will not be
altered.

.TP
.BI "\-t"
Run a terminal program, connecting standard input and output to
.RB \fITTY\fP.

If used in combination with \fB-b\fP, terminal mode is entered immediately
following a successful image upload.

If standard I/O streams connect to a console, this mode will terminate after
receiving 'ctrl-\\' followed by 'c' from console input.

.TP
.BI "\-B \fIbaudrate\fP"
Adjust the baud rate on \fITTY\fP. Default rate is 115200.

.SH "SEE ALSO"
.PP
\fBmkimage\fP(1)

.SH "AUTHORS"

Plik kwboot po zmienie nazwy pliku na kwboot.tar.gz wyświetla "wystąpił problem podczas wczytywania archiwum"


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 17 sie 2020, 14:14 
Offline
Użytkownik

Rejestracja: 17 sie 2020, 13:57
Posty: 1
Dzień dobry, mam na pokładzie openwrt ale niestety nie mogę się dostać do LANu(serwer DHCP nie przydziela adresu). Możecie zerknąć w log:? Procedura wg opisu:
https://eko.one.pl/?p=openwrt-nsa310
Z góry dziękuję za pomoc!


U-Boot 2019.01 (May 16 2020 - 18:32:20 +0000)
ZyXEL NSA310 1-Bay Power Media Server

SoC:   Kirkwood 88F6281_A1
DRAM:  256 MiB
NAND:  128 MiB
MMC:
Loading Environment from NAND... OK
In:    serial
Out:   serial
Err:   serial
Net:   egiga0
PHY reset timed out
MV88E1318 PHY initialized on egiga0
Hit any key to stop autoboot:  0
ubi0: attaching mtd3
ubi0: scanning is finished
ubi0: attached mtd3 (name "ubi", size 126 MiB)
ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 129024 bytes
ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 512
ubi0: VID header offset: 512 (aligned 512), data offset: 2048
ubi0: good PEBs: 1013, bad PEBs: 1, corrupted PEBs: 0
ubi0: user volume: 3, internal volumes: 1, max. volumes count: 128
ubi0: max/mean erase counter: 2/0, WL threshold: 4096, image sequence number: 428444877
ubi0: available PEBs: 0, total reserved PEBs: 1013, PEBs reserved for bad PEB handling: 19
No size specified -> Using max size (2193408)
Read 2193408 bytes from volume kernel to 00800000
## Booting kernel from Legacy Image at 00800000 ...
   Image Name:   ARM OpenWrt Linux-4.14.180
   Created:      2020-05-16  18:32:20 UTC
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2081562 Bytes = 2 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK

Starting kernel ...

[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Linux version 4.14.180 (builder@buildhost) (gcc version 7.5.0 (OpenWrt GCC 7.5.0 r11063-85e04e9f46)) #0 Sat May 16 18:32:20 2020
[    0.000000] CPU: Feroceon 88FR131 [56251311] revision 1 (ARMv5TE), cr=0005397f
[    0.000000] CPU: VIVT data cache, VIVT instruction cache
[    0.000000] OF: fdt: Machine model: ZyXEL NSA310b
[    0.000000] Memory policy: Data cache writeback
[    0.000000] random: get_random_bytes called from 0xc0700980 with crng_init=0
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 65024
[    0.000000] Kernel command line: console=ttyS0,115200
[    0.000000] PID hash table entries: 1024 (order: 0, 4096 bytes)
[    0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Memory: 252208K/262144K available (4807K kernel code, 163K rwdata, 728K rodata, 1024K init, 208K bss, 9936K reserved, 0K cma-reserved)
[    0.000000] Virtual kernel memory layout:
[    0.000000]     vector  : 0xffff0000 - 0xffff1000   (   4 kB)
[    0.000000]     fixmap  : 0xffc00000 - 0xfff00000   (3072 kB)
[    0.000000]     vmalloc : 0xd0800000 - 0xff800000   ( 752 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xd0000000   ( 256 MB)
[    0.000000]     modules : 0xbf000000 - 0xc0000000   (  16 MB)
[    0.000000]       .text : 0xc0008000 - 0xc05b1cd0   (5800 kB)
[    0.000000]       .init : 0xc0700000 - 0xc0800000   (1024 kB)
[    0.000000]       .data : 0xc0800000 - 0xc0828c20   ( 164 kB)
[    0.000000]        .bss : 0xc0828c20 - 0xc085d004   ( 209 kB)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 16, nr_irqs: 16, preallocated irqs: 16
[    0.000000] clocksource: orion_clocksource: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 9556302233 ns
[    0.000008] sched_clock: 32 bits at 200MHz, resolution 5ns, wraps every 10737418237ns
[    0.000038] Switching to timer-based delay loop, resolution 5ns
[    0.000120] Calibrating delay loop (skipped), value calculated using timer frequency.. 400.00 BogoMIPS (lpj=2000000)
[    0.000143] pid_max: default: 32768 minimum: 301
[    0.000273] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.000293] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.000829] CPU: Testing write buffer coherency: ok
[    0.001580] Setting up static identity map for 0x100000 - 0x10003c
[    0.001847] mvebu-soc-id: MVEBU SoC ID=0x6281, Rev=0x3
[    0.005289] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.005315] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.005398] pinctrl core: initialized pinctrl subsystem
[    0.006419] NET: Registered protocol family 16
[    0.006761] DMA: preallocated 256 KiB pool for atomic coherent allocations
[    0.007676] cpuidle: using governor ladder
[    0.008032] Feroceon L2: Enabling L2
[    0.008076] Feroceon L2: Cache support initialised.
[    0.011880] No ATAGs?
[    0.027797] SCSI subsystem initialized
[    0.028461] usbcore: registered new interface driver usbfs
[    0.028518] usbcore: registered new interface driver hub
[    0.028573] usbcore: registered new device driver usb
[    0.030443] clocksource: Switched to clocksource orion_clocksource
[    0.031223] NET: Registered protocol family 2
[    0.031801] TCP established hash table entries: 2048 (order: 1, 8192 bytes)
[    0.031836] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
[    0.031866] TCP: Hash tables configured (established 2048 bind 2048)
[    0.031941] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.031963] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.032093] NET: Registered protocol family 1
[    0.033197] Crashlog allocated RAM at address 0x3f00000
[    0.034798] workingset: timestamp_bits=30 max_order=16 bucket_order=0
[    0.039005] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.039019] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.046575] io scheduler noop registered
[    0.046589] io scheduler deadline registered (default)
[    0.047756] kirkwood-pinctrl f1010000.pin-controller: registered pinctrl driver
[    0.049185] mvebu-pcie mbus@f1000000:pcie@82000000: PCI host bridge to bus 0000:00
[    0.049205] pci_bus 0000:00: root bus resource [io  0x1000-0xfffff]
[    0.049216] pci_bus 0000:00: root bus resource [mem 0xe0000000-0xefffffff]
[    0.049227] pci_bus 0000:00: root bus resource [bus 00-ff]
[    0.049455] PCI: bus0: Fast back to back transfers disabled
[    0.049470] pci 0000:00:01.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    0.049895] PCI: bus1: Fast back to back transfers disabled
[    0.049948] pci 0000:00:01.0: BAR 8: assigned [mem 0xe0000000-0xe00fffff]
[    0.049962] pci 0000:00:01.0: BAR 7: assigned [io  0x10000-0x10fff]
[    0.049979] pci 0000:01:00.0: BAR 6: assigned [mem 0xe0000000-0xe000ffff pref]
[    0.049994] pci 0000:01:00.0: BAR 4: assigned [mem 0xe0010000-0xe0013fff 64bit pref]
[    0.050015] pci 0000:01:00.0: BAR 2: assigned [mem 0xe0014000-0xe0014fff 64bit pref]
[    0.050034] pci 0000:01:00.0: BAR 0: assigned [io  0x10000-0x100ff]
[    0.050048] pci 0000:00:01.0: PCI bridge to [bus 01]
[    0.050059] pci 0000:00:01.0:   bridge window [io  0x10000-0x10fff]
[    0.050072] pci 0000:00:01.0:   bridge window [mem 0xe0000000-0xe00fffff]
[    0.050546] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.052311] console [ttyS0] disabled
[    0.052379] f1012000.serial: ttyS0 at MMIO 0xf1012000 (irq = 26, base_baud = 12500000) is a 16550A
[    0.566600] console [ttyS0] enabled
[    0.571155] sata_mv f1080000.sata: slots 32 ports 2
[    0.579375] scsi host0: sata_mv
[    0.583053] scsi host1: sata_mv
[    0.586351] ata1: SATA max UDMA/133 irq 32
[    0.590498] ata2: SATA max UDMA/133 irq 32
[    0.595076] nand: device found, Manufacturer ID: 0xec, Chip ID: 0xf1
[    0.601482] nand: Samsung NAND 128MiB 3,3V 8-bit
[    0.606123] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[    0.613749] Scanning device for bad blocks
[    0.666299] Bad eraseblock 507 at 0x000003f60000
[    0.720214] 3 fixed-partitions partitions found on MTD device orion_nand
[    0.726960] Creating 3 MTD partitions on "orion_nand":
[    0.732135] 0x000000000000-0x0000000c0000 : "uboot"
[    0.737565] 0x0000000c0000-0x000000140000 : "uboot_env"
[    0.743309] 0x000000140000-0x000008000000 : "ubi"
[    0.749419] libphy: Fixed MDIO Bus: probed
[    0.753775] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.760335] ehci-pci: EHCI PCI platform driver
[    0.764865] ehci-orion: EHCI orion driver
[    0.769049] orion-ehci f1050000.ehci: EHCI Host Controller
[    0.774601] orion-ehci f1050000.ehci: new USB bus registered, assigned bus number 1
[    0.782436] orion-ehci f1050000.ehci: irq 30, io mem 0xf1050000
[    0.810464] orion-ehci f1050000.ehci: USB 2.0 started, EHCI 1.00
[    0.817056] hub 1-0:1.0: USB hub found
[    0.821051] hub 1-0:1.0: 1 port detected
[    0.825428] usbcore: registered new interface driver usb-storage
[    0.831847] rtc-mv f1010300.rtc: rtc core: registered f1010300.rtc as rtc0
[    0.838822] i2c /dev entries driver
[    0.843433] orion_wdt: Initial timeout 21 sec
[    0.854162] marvell-cesa f1030000.crypto: CESA device successfully registered
[    0.862194] NET: Registered protocol family 10
[    0.868221] Segment Routing with IPv6
[    0.872003] NET: Registered protocol family 17
[    0.876500] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    0.889532] 8021q: 802.1Q VLAN Support v1.8
[    0.896511] UBI: auto-attach mtd2
[    0.899852] ubi0: attaching mtd2
[    1.076909] ubi0: scanning is finished
[    1.092291] ubi0: attached mtd2 (name "ubi", size 126 MiB)
[    1.097857] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 129024 bytes
[    1.104781] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 512
[    1.111522] ubi0: VID header offset: 512 (aligned 512), data offset: 2048
[    1.118335] ubi0: good PEBs: 1013, bad PEBs: 1, corrupted PEBs: 0
[    1.124474] ubi0: user volume: 3, internal volumes: 1, max. volumes count: 128
[    1.131745] ubi0: max/mean erase counter: 2/0, WL threshold: 4096, image sequence number: 428444877
[    1.140847] ubi0: available PEBs: 0, total reserved PEBs: 1013, PEBs reserved for bad PEB handling: 19
[    1.150847] block ubiblock0_1: created from ubi0:1(rootfs)
[    1.156355] ubiblock: device ubiblock0_1 (rootfs) set to be root filesystem
[    1.163557] rtc-mv f1010300.rtc: setting system clock to 2020-08-17 11:23:37 UTC (1597663417)
[    1.172548] ata1: SATA link down (SStatus 0 SControl F300)
[    1.178245] ubi0: background thread "ubi_bgt0d" started, PID 451
[    1.240462] usb 1-1: new high-speed USB device number 2 using orion-ehci
[    1.442560] hub 1-1:1.0: USB hub found
[    1.446699] hub 1-1:1.0: 4 ports detected
[    1.512153] ata2: SATA link down (SStatus 0 SControl F300)
[    1.522190] VFS: Mounted root (squashfs filesystem) readonly on device 254:0.
[    1.532224] Freeing unused kernel memory: 1024K
[    1.730466] random: fast init done
[    1.843159] init: Console is alive
[    1.846726] init: - watchdog -
[    1.982995] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    2.049767] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    2.067368] init: - preinit -
[    2.569895] random: jshn: uninitialized urandom read (4 bytes read)
[    2.606065] random: jshn: uninitialized urandom read (4 bytes read)
[    2.849048] random: jshn: uninitialized urandom read (4 bytes read)
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[    6.114116] UBIFS (ubi0:2): background thread "ubifs_bgt0_2" started, PID 543
[    6.147606] UBIFS (ubi0:2): recovery needed
[    6.289248] UBIFS (ubi0:2): recovery completed
[    6.293817] UBIFS (ubi0:2): UBIFS: mounted UBI device 0, volume 2, name "rootfs_data"
[    6.301696] UBIFS (ubi0:2): LEB size: 129024 bytes (126 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[    6.311673] UBIFS (ubi0:2): FS size: 122314752 bytes (116 MiB, 948 LEBs), journal size 6064128 bytes (5 MiB, 47 LEBs)
[    6.322341] UBIFS (ubi0:2): reserved for root: 4952683 bytes (4836 KiB)
[    6.328983] UBIFS (ubi0:2): media format: w4/r0 (latest is w5/r0), UUID E694CD51-AA43-4F5C-B327-03CA29B757B5, small LPT model
[    6.342802] mount_root: switching to ubifs overlay
[    6.359773] urandom-seed: Seeding with /etc/urandom.seed
[    6.408332] procd: - early -
[    6.411784] procd: - watchdog -
[    7.028000] procd: - watchdog -
[    7.031395] procd: - ubus -
[    7.112976] urandom_read: 3 callbacks suppressed
[    7.112982] random: ubusd: uninitialized urandom read (4 bytes read)
[    7.161027] random: ubusd: uninitialized urandom read (4 bytes read)
[    7.167775] random: ubusd: uninitialized urandom read (4 bytes read)
[    7.175146] procd: - init -
Please press Enter to activate this console.
[    7.503853] kmodloader: loading kernel modules from /etc/modules.d/*
[    7.525111] ip6_tables: (C) 2000-2006 Netfilter Core Team
[    7.547768] ip_tables: (C) 2000-2006 Netfilter Core Team
[    7.562773] hwmon_vid: Unknown VRM version of your CPU
[    7.580471] lm85 0-002e: Starting monitoring
[    7.588908] nf_conntrack version 0.5.0 (4096 buckets, 16384 max)
[    7.639407] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    7.645087] pci 0000:00:01.0: enabling device (0140 -> 0143)
[    7.650811] r8169 0000:01:00.0: enabling device (0140 -> 0143)
[    7.657500] r8169 0000:01:00.0 eth0: RTL8168d/8111d at 0xd0b4c000, 00:00:00:00:00:30, XID 083000c0 IRQ 36
[    7.667139] r8169 0000:01:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[    7.724950] urngd: v1.0.2 started.
[    7.814808] xt_time: kernel timezone is -0000
[    7.836056] PPP generic driver version 2.4.2
[    7.842039] NET: Registered protocol family 24
[    7.862495] kmodloader: done loading kernel modules from /etc/modules.d/*
[    7.935963] random: crng init done
[    7.939391] random: 1 urandom warning(s) missed due to ratelimiting
[   13.200631] r8169 0000:01:00.0 eth0: link down
[   13.205476] r8169 0000:01:00.0 eth0: link down
[   13.213792] br-lan: port 1(eth0) entered blocking state
[   13.219066] br-lan: port 1(eth0) entered disabled state
[   13.224572] device eth0 entered promiscuous mode
[   13.250641] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   15.533042] r8169 0000:01:00.0 eth0: link up
[   15.538125] br-lan: port 1(eth0) entered blocking state
[   15.543396] br-lan: port 1(eth0) entered forwarding state
[   15.550156] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready


Edit:
Okazało się,że MAC adres nie ustawił się wg opisu na eko.one.pl. Połączyłem się raz jeszcze po serialu i wbiłem polecenie w openwrt:
uci set network.lan.macaddr=MAC urządzenia
uci commit

Jest już dostęp. Pozdrawiam


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 17 sie 2020, 15:35 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 13956
Lokalizacja: Warszawa
To znaczy że w bootloaderze nie ustawiłeś lub masz tam dwa razy wpisane (!) - w partycji, czytanie przez strings, nie w printenv.

Mac jest czytany w https://github.com/openwrt/openwrt/blob ... etwork#L35 przez mtd_get_mac_ascii które korzysta z macaddr_canonicalize. Jak jest dwa razy to string jest większy niż 17 znaków i nic nie robi.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 25 lut 2021, 18:19 
Offline
Użytkownik

Rejestracja: 17 lis 2011, 10:51
Posty: 325
Jakie macie prędkości kopiowania na NSA310 po FTP na Luci lub jakie powinny być?
Czy po sambie czy po ftp mam maksymalną prędkość do 19MB/s - da się to zwiększyć?


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 26 lut 2021, 19:22 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 13956
Lokalizacja: Warszawa
Nie, sprawdziłem na swoim. Nie chce przejść tej granicy.

EDIT: poprawka: 35 - 37MB/s

openwrt, dysk zwykły (HDD) na ext4, plik 800MB, po ftp. Może by było więcej jak bym SSD wsadził, ale chwilowo nie mam wolnego pod ręką.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 15 mar 2021, 23:49 
Offline
Użytkownik

Rejestracja: 15 mar 2021, 23:36
Posty: 1
Przy sprawdzaniu czy jest najnowsza wersja oprogramowania wyskakuje mi " Nie znaleziono zdalnego pliku."
Mam wgrane orginalne oprogramowanie w wersji V4.70(AFK.3).

Lista pakietów niby jest ale nic nie mogę zainstalować ani nic się nie pobiera w internecie też nic nie mogę znaleźć.

Może ktoś pomoże.


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 17 mar 2021, 15:53 
Offline
Użytkownik
Awatar użytkownika

Rejestracja: 24 cze 2014, 18:39
Posty: 14
Cześć,
próbuję zainstalować ownCloud na tym poczciwym Zyxelu i trafiam na kolejne kłody pod nogi. W końcu poległem, ale po kolei...

- w paczkach zyxelowych jest ownCloud 5.0.8zypkg002 i niby spoko, ale odpalona apka na telefonie od razu stwierdza, że z wersją <10 nie będzie współpracować... jakoś udało mi się zaktualizować to do najnowszej wersji 10.6 no i zaczęło się...

This version of ownCloud requires at least PHP 7.2.0
You are currently running PHP 5.4.12. Please update your PHP version.


- ściągnąłem paczkę php-7.4.16 i nie mogę jej zainstalować bo ani ./configure ani autoconf nie działa...

root@NAS:/i-data/0baeb22e/admin/php-7.4.16# ./configure
checking for grep that handles long lines and -e... /ffp/bin/grep
checking for egrep... /ffp/bin/grep -E
checking for a sed that does not truncate output... /ffp/bin/sed
checking build system type... armv5tel-unknown-linux-gnueabi
checking host system type... armv5tel-unknown-linux-gnueabi
checking target system type... armv5tel-unknown-linux-gnueabi
checking for pkg-config... /ffp/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for cc... cc
checking whether the C compiler works... no
configure: error: in `/i-data/0baeb22e/admin/php-7.4.16':
configure: error: C compiler cannot create executables
See `config.log' for more details
root@NAS:/i-data/0baeb22e/admin/php-7.4.16# autoconf
autom4te: need GNU m4 1.4 or later: /ffp/bin/m4
root@NAS:/i-data/0baeb22e/admin/php-7.4.16#


- z pierwszej opcji log zdradza tyle:
root@NAS:/i-data/0baeb22e/admin/php-7.4.16# cat config.log | grep error
configure:4232: error: in `/i-data/0baeb22e/admin/php-7.4.16':
configure:4234: error: C compiler cannot create executables


- druga opcja wymaga zainstalowania "GNU m4 1.4 or later", znalazłem więc paczkę m4-1.4.18, ale jest ten sam problem
root@NAS:/i-data/0baeb22e/admin/m4-1.4.18# ./configure
checking for a BSD-compatible install... /ffp/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /ffp/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether make supports nested variables... (cached) yes
checking for gcc... gcc
checking whether the C compiler works... no
configure: error: in `/i-data/0baeb22e/admin/m4-1.4.18':
configure: error: C compiler cannot create executables
See `config.log' for more details

root@NAS:/i-data/0baeb22e/admin/m4-1.4.18# cat config.log | grep error
configure:4810: error: in `/i-data/0baeb22e/admin/m4-1.4.18':
configure:4812: error: C compiler cannot create executables


z tym nie potrafię sobie poradzić.... any help?


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 17 mar 2021, 22:40 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 13956
Lokalizacja: Warszawa
Na nasie się nie kompiluje źródeł. Masz mieć już gotową skompilowaną paczkę z daną wersję php.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 17 mar 2021, 23:32 
Offline
Użytkownik
Awatar użytkownika

Rejestracja: 24 cze 2014, 18:39
Posty: 14
parę rzeczy już kompilowałem i szło, ale to jakiś czas temu
paczki nie widzę takiej....
---edit---
ok, znalazłem paczkę, zainstalowałem, ale z jakiegoś powodu apache nadal używa php5 zamiast php7 - jak to zmienić?

PS mam FFP0.7


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 30 wrz 2021, 09:49 
Offline
Użytkownik

Rejestracja: 30 wrz 2021, 09:45
Posty: 2
Witam,
mam problem z moim zyxelem NSA310.
Chciałem wgrać Debiana + OMV
Oczywiście coś źle zrobiłem i zyxel nie wstaje.
Przez kwboot obraz uboota przechodzi i zyxel się odpala lecz działa tylko do momemntu gdy ma zasilanie (ładowany do RAM).
Uboot z USB wgrywa się lecz nie za bardzo wiem w jaki obszar go wgrać.
Ruszone mam też chyba partycje.
Zerknie ktoś fachowym okiem i podpowie jakie zmienne ustawić i jak ustawić partycje aby poprawnie zyxel bootował z ubota z NAND ?
NSA310> mtdparts

device nand0 <orion_nand>, # parts = 3
 #: name      size      offset      mask_flags
 0: uboot               0x000c0000   0x00000000   0
 1: uboot_env           0x00080000   0x000c0000   0
 2: ubi                 0x07ec0000   0x00140000   0

active partition: nand0,0 - (uboot) 0x000c0000 @ 0x00000000

defaults:
mtdids  :
mtdparts: mtdparts=orion_nand:0x0c0000(uboot),0x80000(uboot_env),0x7ec0000(ubi)
NSA310> printenv
baudrate=115200
bootcmd=ubi part ubi; ubi read 0x800000 kernel; bootm 0x800000
bootdelay=3
console=console=ttyS0,115200
ethact=egiga0
ipaddr=192.168.1.1
mtddevname=uboot
mtddevnum=0
mtdids=nand0=orion_nand
mtdparts=mtdparts=orion_nand:0x0c0000(uboot),0x80000(uboot_env),0x7ec0000(ubi)
partition=nand0,0
serverip=192.168.1.2
stderr=serial
stdin=serial
stdout=serial

Environment size: 366/131068 bytes


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 30 wrz 2021, 09:55 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 13956
Lokalizacja: Warszawa
ubi. Żadnej innej partycji nie masz dostepnej i zniej się chce uruchamiać.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 30 wrz 2021, 11:55 
Offline
Użytkownik

Rejestracja: 6 maja 2010, 21:55
Posty: 536
obsy pisze:
ubi. Żadnej innej partycji nie masz dostepnej i zniej się chce uruchamiać.

A tak z ciekawości, od kiedy jest ubifs? Od czasu przekompilowanego uboota?
Jak kojarzę nandu było sporo, żeby zmieścić jądro i initrd i jeszcze druga kopia była w nandzie.


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 30 wrz 2021, 12:02 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 13956
Lokalizacja: Warszawa
Strzelam ze bootloader jest z openwrt i to dlatego.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 30 wrz 2021, 13:38 
Offline
Użytkownik

Rejestracja: 30 wrz 2021, 09:45
Posty: 2
Naprawiłem partycje za pomocą komendy
fw_setenv mtdparts 'mtdparts=orion_nand:0x100000(uboot),0x80000(uboot_env),0x80000(key_store),0x80000(info),0xA00000(etc),0xA00000(kernel_1),0x2FC0000(rootfs1),0xA00000(kernel_2),0x2FC0000(rootfs2)'

Teraz wygląda to tak i udało mi się wgrać uboota.
Tylko czy wszystko wygląda ok ?
# Proszę o weryfikację ewentualnie wskazówki co poprawić.
Bootuje mi nawet Debiana z Pen USB a chciałbym go przenieść do NAND tylko chyba się nie pomieści ?
Zalezy mi na tym aby Debiana postawić z obsługą LED na panelu oraz zarządzaniem chłodzeniem wentylatora + oprogramowanie OMV.
# Co to za serverip w ENV ? Za co to odpowiada ?
# Jak ustawić prawidłowy MAC ADRES ?

NSA310> mtdparts
NSA310> mtdparts

device nand0 <orion_nand>, # parts = 9
 #: name                size            offset          mask_flags
 0: uboot               0x00100000      0x00000000      0
 1: stock_uboot_env     0x00080000      0x00100000      0
 2: key_store           0x00080000      0x00180000      0
 3: info                0x00080000      0x00200000      0
 4: etc                 0x00a00000      0x00280000      0
 5: kernel_1            0x00a00000      0x00c80000      0
 6: rootfs1             0x02fc0000      0x01680000      0
 7: kernel_2            0x00a00000      0x04640000      0
 8: rootfs2             0x02fc0000      0x05040000      0

active partition: nand0,2 - (key_store) 0x00080000 @ 0x00180000

defaults:
mtdids  : none
mtdparts: none
NSA310> NSA310> mtdparts
Unknown command 'NSA310>' - try 'help'
NSA310>
Unknown command 'NSA310>' - try 'help'
NSA310> device nand0 <oemask_flags
Unknown command 'device' - try 'help'
NSA310>  0: uboot       tock_uboot_env     0x00080000      0x00100000      0
Unknown command '0:' - try 'help'
NSA310>  2: key_store   3: info                0x00080000      0x00200000      0
Unknown command '2:' - try 'help'
NSA310>  4: etc         5: kernel_1            0x00a00000      0x00c80000      0
Unknown command '4:' - try 'help'
NSA310>  6: rootfs1     7: kernel_2            0x00a00000      0x04640000      0
Unknown command '6:' - try 'help'
NSA310>  8: rootfs2     active partition: nand0,2 - (key_store) 0x00080000 @ 0x00180000
Unknown command '8:' - try 'help'
NSA310>
Unknown command '8:' - try 'help'
NSA310> defaults:
Unknown command 'defaults:' - try 'help'
NSA310> printenv
arcNumber=4022
baudrate=115200
bootcmd=run bootcmd_uenv; run scan_disk; run set_bootargs; run bootcmd_exec; reset
bootcmd_exec=run load_uimage; if run load_initrd; then if run load_dtb; then bootm $load_uimage_addr $load_initrd_addr $load_dtb_addr; else bootm $load_uimage_addr $load_initrd_addr; fi; else if run load_dtb; then bootm $load_uimage_addr - $load_dtb_addr; else bootm$load_uimage_addr; fi; fi
bootcmd_uenv=run uenv_load; if test $uenv_loaded -eq 1; then run uenv_import; fi
bootdelay=10
bootdev=usb
console=ttyS0,115200
device=0:1
devices=usb ide
disks=0 1 2 3
dtb_file=/boot/dts/kirkwood-nsa310.dtb
ethact=egiga0
ethaddr=52:3b:20:9c:11:51
fileaddr=800000
filesize=80000
if_netconsole=ping $serverip
ipaddr=192.168.0.231
led_error=orange blinking
led_exit=green off
led_init=green blinking
load_dtb=echo loading DTB $dtb_file ...; load $bootdev $device $load_dtb_addr $dtb_file
load_dtb_addr=0x1c00000
load_initrd=echo loading uInitrd ...; load $bootdev $device $load_initrd_addr /boot/uInitrd
load_initrd_addr=0x1100000
load_uimage=echo loading uImage ...; load $bootdev $device $load_uimage_addr /boot/uImage
load_uimage_addr=0x800000
mainlineLinux=yes
mtddevname=key_store
mtddevnum=2
mtdids=nand0=orion_nand
mtdparts=mtdparts=orion_nand:0x100000(uboot),0x80000(stock_uboot_env),0x80000(key_store),0x80000(info),0xA00000(etc),0xA00000(kernel_1),0x2FC0000(rootfs1),0xA00000(kernel_2),0x2FC0000(rootfs2)
partition=nand0,2
preboot_nc=run if_netconsole start_netconsole
scan_disk=echo running scan_disk ...; scan_done=0; setenv scan_usb "usb start";  setenv scan_ide "ide reset";  setenv scan_mmc "mmc rescan"; for dev in $devices; do if test $scan_done -eq 0; then echo Scan device $dev; run scan_$dev; for disknum in $disks; do if test $scan_done -eq 0; then echo device $dev $disknum:1; if load $dev $disknum:1 $load_uimage_addr /boot/uImage 1; then scan_done=1; echo Found bootable drive on $dev $disknum; setenv device $disknum:1; setenv bootdev $dev; fi; fi; done; fi; done
serverip=192.168.0.220
set_bootargs=setenv bootargs console=ttyS0,115200 root=LABEL=rootfs rootdelay=10 $mtdparts $custom_params
start_netconsole=setenv ncip $serverip; setenv bootdelay 10; setenv stdin nc; setenv stdout nc; setenv stderr nc; version;
stderr=serial
stdin=serial
stdout=serial
uenv_addr=0x810000
uenv_import=echo importing envs ...; env import -t $uenv_addr $filesize
uenv_init_devices=setenv init_usb "usb start";  setenv init_ide "ide reset";  setenv init_mmc "mmc rescan"; for devtype in $devices; do run init_$devtype; done;
uenv_load=run uenv_init_devices; setenv uenv_loaded 0; for devtype in $devices;  do for disknum in 0; do run uenv_read_disk; done; done;
uenv_read=echo loading envs from $devtype $disknum ...; if load $devtype $disknum:1 $uenv_addr /boot/uEnv.txt; then setenv uenv_loaded 1; fi
uenv_read_disk=if test $devtype -eq mmc; then if $devtype part; then run uenv_read;  fi; else if $devtype part $disknum; then run uenv_read; fi;  fi
usb_ready_retry=15

Environment size: 3080/131068 bytes



Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat Odpowiedz w temacie  [ Posty: 2037 ]  Przejdź na stronę Poprzednia  1 ... 98, 99, 100, 101, 102

Strefa czasowa UTC+1godz. [letni]


Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 17 gości


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów

Szukaj:
Przejdź do:  
cron
designed by digi-led.pl
...Copyright © 2010-2013, Ekipa openrouter.info