Ostatnio Na Forum
Logowanie

Polityka prywatno?ci

Portal openrouter.info stosuje pliki cookies ("ciasteczka") pozwalające na dostosowanie zawartości portalu do indywidualnych potrzeb. Korzystanie z portalu bez zmiany ustawień dotyczących ciasteczek oznacza akceptację umieszczenia ich na urządzenia użytkownika. Zmianę ustawień pliku ciasteczek można wykonać zmieniając opcję w ustawieniach przeglądarki internetowej. Więcej informacji można znaleźć w Polityce prywatności.

Tor - Anonimowo?? w sieci

Email Drukuj

O sieci Tor napisano ju? naprawd? du?o - oglnie ujmuj?c, jest to sie? nastawiona na anonimowo?? dzi?ki ktrej mo?liwe jest przegl?danie internetu i wypowiadanie swoich opinii bez nara?ania si? na wykrycie. Jest to wa?ne np. dla dziennikarzy czy w krajach w ktrych obowi?zuje ostra cenzura. Ma to tak?e drug? stron? medalu - sie? Tor uwa?ana jest za woln?, pe?n? z?ych tre?ci i osb z ktrymi zwykle nie chcemy za wiele mie? wsplnego (np. pedofilii).

Wa?ne jest zapoznanie si? opisem czym jest sie? Tor, jakie ma wady i zalety. Napisano ju? wiele na ten temat; dobrym punktem wyj?cia jest strona domowa projektu oraz FAQ.

http://www.torproject.org/

http://pl.wikipedia.org/wiki/Tor_%28sie%C4%87_anonimowa%29

http://www.torproject.org/docs/faq.html.en

Celem zaprezentowanego projektu jest utworzenie konfiguracji routera opartej o OpenWrt umo?liwiaj?cej ca?kowicie przezroczyste korzystanie z sieci Tor - nie wymaga to instalowania dodatkowego oprogramowania na komputerze klienta, wi?c mo?e tak?e s?u?y? np. jako konfiguracja otwartego hostpota. Do projektu wykorzystano router TP-Link TL-MR3420, ale mo?e to by? dowolny inny. Wymagane jest za to minimum 32MB ramu - przy mniejszej ilo?ci Tor mo?e si? uruchomi?, ale b?dzie chodzi? bardzo powoli.

Konfiguracja zostanie wykonana w taki sposb, aby ca?y ruch by? przesy?any bezpo?rednio przez sie? Tor, ??cznie z zapytaniami o dns. ?rd?em internetu b?dzie port wan, natomiast dost?p do routera i sieci b?dzie odbywa? si? bezprzewodowo (interfejsem radiowym - wlan0).

Instalacja

Przebiega standardowo, jak ka?dej innej paczki w systemie:

opkg update
opkg install tor
opkg install iptables-mod-nat-extra
/etc/init.d/tor enable

Tworzymy now? sekcje sieci w pliku /etc/config/network

config interface tor
option ifname wlan0
option proto static
option ipaddr 192.168.2.1
option netmask 255.255.255.0

Tworzymy nowy zakres adresw przyznawanych przez dhcp (/etc/config/dhcp)

config dhcp tor
option interface tor
option start 100
option stop 150
option leasetime 2h

Oraz konfigurujemy odpowiednio firewall dla tej sekcji. Dopuszczamy ruch z interfejsu tor do wanu, a tak?e przekierowujemy ca?y ruch do tora. Do pliku /etc/config/firewall dodajemy:

config zone
option name tor
option network tor
option input REJECT
option output ACCEPT
option forward REJECT
option syn_flood 1
option conntrack 1

config rule
option src tor
option proto udp
option dest_port 67
option target ACCEPT

config rule
option src tor
option proto tcp
option dest_port 9040
option target ACCEPT

config rule
option src tor
option proto udp
option dest_port 9053
option target ACCEPT

Oraz do pliku /etc/firewall.user odpowiednie przekierowanie ca?ego ruchu i zapyta? do Tora:

iptables -t nat -A PREROUTING -i wlan0 -p udp --dport 53 -j REDIRECT --to-ports 9053
iptables -t nat -A PREROUTING -i wlan0 -p tcp --syn -j REDIRECT --to-ports 9040

Konfiguracja interfejsu radiowego (/etc/config/wireless) jest prawie standardowa (tu taktujemy go jako otwarty hostspot, mo?na tak?e ustawi? np. WPA2 z has?em). Nale?y tak?e pami?ta? o w??czeniu interfejsu (usuni?ciu opcji disabled!):

config wifi-iface
option device radio0
option network tor
option mode ap
option ssid hotspot
option encryption none

Sama konfiguracja tora nie jest zbyt skompilowana i zamyka sie w paru liniach (do zapisania w pliku /etc/tor/torrc):

VirtualAddrNetwork 10.192.0.0/10
AutomapHostsOnResolve 1
TransPort 9040
TransListenAddress 192.168.2.1
DNSPort 9053
DNSListenAddress 192.168.2.1
DataDirectory /tmp/.tor
RunAsDaemon 1
User nobody
Log notice file /tmp/tor.log

Tor podczas dzia?ania zapisuje pewnie informacje o dost?pie do sieci w plikach. Je?eli nie zostanie okre?lony katalog DataDirectory, zrobi to w /root/.tor skutecznie zapychajac flash. Opcja Log u?atwia p?niejsze diagnozowanie po??czenia.

Tak zrobiona konfguracja pozwala do dost?p do sieci, ale nie do routera (je?eli chcemy mie? dost?p nale?y odblokowa? odpowiedni port na interfejsie tor). Zostaje tylko zrestartowa? router. W pliku /tmp/tor.log pojawia si? informacja o dzia?aniu tora, mo?na j? odczyta? poleceniem

tail -f /tmp/tor.log

Pierwsze uruchomienie mo?e potrwa? chwil?, dopki nie zostan? zebrane dane niezb?dne do po?aczenia. Mo?e to wygl?da? nast?puj?co:

Jan 25 07:16:41.314 [notice] Tor v0.2.1.29 (r8e9b25e6c7a2e70c). This is experimental software. Do not rely on it for strong anonymity. (Running on Linux mips)
Jan 25 07:16:42.024 [notice] Initialized libevent version 2.0.10-stable using method poll. Good.
Jan 25 07:16:42.027 [notice] Opening Socks listener on 127.0.0.1:9050
Jan 25 07:16:42.029 [notice] Opening Transparent pf/netfilter listener on 192.168.2.1:9040
Jan 25 07:16:42.031 [notice] Opening DNS listener on 192.168.2.1:9053
Jan 25 07:16:49.099 [notice] No current certificate known for authority tor26; launching request.
Jan 25 07:16:49.100 [notice] No current certificate known for authority dizum; launching request.
Jan 25 07:16:49.101 [notice] No current certificate known for authority ides; launching request.
Jan 25 07:16:49.101 [notice] No current certificate known for authority gabelmoo; launching request.
Jan 25 07:16:49.102 [notice] No current certificate known for authority dannenberg; launching request.
Jan 25 07:16:49.103 [notice] No current certificate known for authority urras; launching request.
Jan 25 07:16:49.104 [notice] No current certificate known for authority maatuska; launching request.
Jan 25 07:16:49.109 [notice] Bootstrapped 5%: Connecting to directory server.
Jan 25 07:16:49.115 [notice] I learned some more directory information, but not enough to build a circuit: We have no network-status consensus.
Jan 25 07:16:49.169 [notice] Bootstrapped 10%: Finishing handshake with directory server.
Jan 25 07:16:51.003 [notice] Bootstrapped 15%: Establishing an encrypted directory connection.
Jan 25 07:16:51.203 [notice] Bootstrapped 20%: Asking for networkstatus consensus.
Jan 25 07:16:51.256 [notice] Bootstrapped 25%: Loading networkstatus consensus.
Jan 25 07:16:53.497 [warn] 2 unknown, 8 missing key, 0 good, 0 bad, 0 no signature, 5 required
Jan 25 07:16:53.559 [notice] I learned some more directory information, but not enough to build a circuit: We have no network-status consensus.
Jan 25 07:16:54.288 [notice] Bootstrapped 40%: Loading authority key certs.
Jan 25 07:16:56.484 [notice] Bootstrapped 45%: Asking for relay descriptors.
Jan 25 07:16:56.485 [notice] I learned some more directory information, but not enough to build a circuit: We have only 0/1992 usable descriptors.
Jan 25 07:17:08.720 [notice] Bootstrapped 50%: Loading relay descriptors.
Jan 25 07:17:11.026 [notice] Bootstrapped 55%: Loading relay descriptors.
Jan 25 07:17:11.031 [notice] I learned some more directory information, but not enough to build a circuit: We have only 96/1992 usable descriptors.
Jan 25 07:17:12.070 [notice] Bootstrapped 61%: Loading relay descriptors.
Jan 25 07:17:12.075 [notice] I learned some more directory information, but not enough to build a circuit: We have only 192/1992 usable descriptors.
Jan 25 07:17:13.696 [notice] Bootstrapped 66%: Loading relay descriptors.
Jan 25 07:17:13.702 [notice] I learned some more directory information, but not enough to build a circuit: We have only 287/1992 usable descriptors.
Jan 25 07:17:14.826 [notice] Bootstrapped 71%: Loading relay descriptors.
Jan 25 07:17:14.831 [notice] I learned some more directory information, but not enough to build a circuit: We have only 377/1992 usable descriptors.
Jan 25 07:17:15.857 [notice] Bootstrapped 77%: Loading relay descriptors.
Jan 25 07:17:15.863 [notice] I learned some more directory information, but not enough to build a circuit: We have only 473/1992 usable descriptors.
Jan 25 07:17:17.369 [notice] We now have enough directory information to build circuits.
Jan 25 07:17:17.370 [notice] Bootstrapped 80%: Connecting to the Tor network.
Jan 25 07:17:32.793 [notice] Bootstrapped 90%: Establishing a Tor circuit.
Jan 25 07:18:32.668 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Jan 25 07:18:33.028 [notice] Bootstrapped 100%: Done.

Do dzia?ania tora niezb?dne jest ustawienie poprawanego czasu, wi?c nale?y to sprawdzi? przed uruchomieniem demona.

Inn? ciekaw? konfiguracj? mo?e by? wykorzystanie wbudowanego prze??cznika. Zwykle routery maj? cztery porty, mo?na podzieli? odpowiednio prze??cznik zostawiaj?c dla interfejsu lan dwa porty, a z dwch pozosta?ych uwtorzy? now? sie? tor. Dzi?ki temu aby uzyska? anonimowe po??czenie wystraczy po prostu przepi?? kabel do odpowiedniego gniazda.

Tor nie zapewnia 100% anonimowo?ci w sieci. Bardzo trudno zidentyfikowa? u?ytkownika korzystaj?cego z takiej sieci, ale jest to mo?liwe. Aby by? jeszcze bardziej anonimowym, nale?y zmienic adres mac routra (aby zmyli? us?ugi geolokalizacyjne). Nale?y tak?e pamieta?, ?e ka?da przegl?dardka zostania prawie niepowtarzalny "odcisk palca", nale?y wi?c korzysta? z popularnych systemw operacyjnych i standardowych (najpopularniejszych) ustawie? przegl?darki i systemu. Zalecane by?o by tak?e np. wy?aczenie ciasteczek w przegl?darce.

Nale?y tak?e pamieta? o systematycznym aktualizowaniu programu tor do najnowszych dost?pnych wersji.

 
Share
designed by digi-led.pl
góra
...Copyright © 2010-2013, Ekipa openrouter.info