Dzisiaj jest 26 kwie 2019, 02:41

Strefa czasowa UTC+1godz. [letni]




Nowy temat Odpowiedz w temacie  [ Posty: 1928 ]  Przejdź na stronę Poprzednia  1 ... 93, 94, 95, 96, 97
Autor Wiadomość
 Tytuł: Re: ZyXEL NSA310
Post: 27 lut 2019, 20:02 
Offline
Użytkownik

Rejestracja: 17 lis 2011, 10:51
Posty: 285
root@OpenWrt:~# ethtool eth0
Settings for eth0:
Cannot get device settings: No such device
        Current message level: 0x000000ff (255)
                               drv probe link timer ifdown ifup rx_err tx_err
        Link detected: yes



Ehh nie pomyślałbym, że mogę napotkać takie problemy... zastanawiam się gdzie to i jak zgłosić - może ktoś by to poprawił :( :roll:


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 27 lut 2019, 22:41 
Offline
Użytkownik

Rejestracja: 17 lis 2011, 10:51
Posty: 285
Zdenerwowany zabrałem sie za instalację OpenWrt...

Już przy pierwszych krokach problem:

NSA310>> fatload usb 0 0x1000000 u-boot.kwb
reading u-boot.kwb
............................................................

621348 bytes read
NSA310>> nand erase.chip
Usage:
nand                   - NAND sub-system

NSA310>> nand erase.chip
Usage:
nand                   - NAND sub-system

NSA310>> nand write 0x1000000 0x00000 0x100000

NAND write: device 0 offset 0x0, size 0x100000
Failed write verify, nand offset 0x00000000. Suggest to erase block and repeat write operation!
 If problem persists suggest marking block as bad (nand markbad <offset>) and repeating the operation!
 0 bytes written: ERROR
NSA310>> usb reset
(Re)start USB...
USB:   scanning bus for devices... 1 USB Device(s) found
       scanning bus for storage devices... 0 Storage Device(s) found


Aktualnie brak jakiejkolwiek komunikacji i wygląda mi na przycisk do papieru.
Z przodu wszystkie diody na czerowno

Jakieś pomysły?


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 27 lut 2019, 22:50 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 13375
Lokalizacja: Warszawa
Tam łatwo się wgrywa się uboot przy pomocy seriala (kwboot)

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 28 lut 2019, 00:20 
Offline
Użytkownik

Rejestracja: 17 lis 2011, 10:51
Posty: 285
Znalazłem taką instrukcję: https://www.dropbox.com/sh/4plbxtlje32t ... _UART.html

Niestety na laptopie mam Windows. Jak przeskoczyć taki problem?

VM cos postawić nie idzie.. bede musial poszukac jakiejs dystrybucji linuxa na pendrive :/


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 28 lut 2019, 07:26 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 13375
Lokalizacja: Warszawa
Przecież możesz sobie uruchomić linuksa live z płyty lub dvd. Nie musisz go instalować.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 28 lut 2019, 21:06 
Offline
Użytkownik

Rejestracja: 17 lis 2011, 10:51
Posty: 285
Udało się przywrócić u-boota, i postępuje zgodnie z instrukcją z https://openwrt.org/toh/zyxel/nsa310b

NSA310> usb reset                                                                                                                                                                                                                            (Re)start USB...
USB0:   USB EHCI 1.00
scanning bus 0 for devices... 3 USB Device(s) found
       scanning usb for storage devices... 1 Storage Device(s) found
NSA310> fatload usb 0 0x1000000 u-boot.kwb                                                                                                                                                                                                   reading u-boot.kwb
621348 bytes read in 51 ms (11.6 MiB/s)
NSA310> nand erase.chip

NAND erase.chip: device 0 whole chip
Skipping bad block at  0x00040000
Skipping bad block at  0x00060000
Skipping bad block at  0x02860000
Erasing at 0x7fe0000 -- 100% complete.
OK
NSA310> nand write 0x1000000 0x00000 0x100000

NAND write: device 0 offset 0x0, size 0x100000
Skip bad block 0x00040000
Skip bad block 0x00060000
 1048576 bytes written: OK
NSA310> reset
resetting ...


U-Boot 2018.03 (Jun 27 2018 - 06:41:13 +0000)
ZyXEL NSA310 1-Bay Power Media Server

SoC:   Kirkwood 88F6281_A1
DRAM:  256 MiB
WARNING: Caches not enabled
NAND:  128 MiB
MMC:
Loading Environment from NAND... *** Warning - bad CRC, using default environmen                                                                                                                                                             t

Failed (-5)
In:    serial
Out:   serial
Err:   serial
Net:   egiga0
Error: egiga0 address not set.

PHY reset timed out
MV88E1318 PHY initialized on egiga0
Hit any key to stop autoboot:  0
NSA310> setenv mtdparts 'mtdparts=orion_nand:0x00c0000(uboot),0x80000(uboot_env)                                                                                                                                                             ,0x7ec0000(ubi)'
NSA310> setenv bootcmd 'run setenv bootargs; ubi part ubi; ubi read 0x800000 ker                                                                                                                                                             nel; bootm 0x800000'
NSA310> saveenv
Saving Environment to NAND... Erasing NAND...
Erasing at 0xc0000 -- 100% complete.
Writing to NAND... OK
OK
NSA310> reset
resetting ...


Na tym kroku nie dochodzi do resetu i wisi wszystko.

Jak go sam zresetuje to zero odpowiedzi i od nowa wgrywanie u-boota.

Co robie źle?

EDIT:

Ok, trzeba było zrobić jeszcze
nand scrub 0x0 0x80000


I poszło. Openwrt wgrane ;)


EDIT2:
Liczyłem, że na OpenWrt złapie adres jak należy widac sie przeliczyłem z tą zmianą :(

[   12.510646] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready



BusyBox v1.28.3 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 18.06.1, r7258-5eb055306f
 -----------------------------------------------------
root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr 50:67:F0:69:2A:CC
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0      Link encap:Ethernet  HWaddr 50:67:F0:69:2A:CC
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1088 (1.0 KiB)  TX bytes:1088 (1.0 KiB)



Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 28 lut 2019, 22:07 
Offline
Użytkownik

Rejestracja: 17 lis 2011, 10:51
Posty: 285
Tak wygląda log z konsoli ładowania openwrt

https://pastebin.com/2Uw0X2qA



Podłączałem wyłączałem kabelek i przez chwile nawet router przydzielił adres.. ehh brak mi sił

Thu Feb 28 21:30:20 2019 kern.info kernel: [171907.025808] mtk_soc_eth 1e100000.ethernet eth0: port 2 link up
Thu Feb 28 21:30:20 2019 daemon.info dnsmasq-dhcp[23696]: DHCPDISCOVER(br-lan) 50:67:f0:69:2a:cc
Thu Feb 28 21:30:20 2019 daemon.info dnsmasq-dhcp[23696]: DHCPOFFER(br-lan) 192.168.1.110 50:67:f0:69:2a:cc
Thu Feb 28 21:30:20 2019 daemon.info dnsmasq-dhcp[23696]: DHCPREQUEST(br-lan) 192.168.1.110 50:67:f0:69:2a:cc
Thu Feb 28 21:30:20 2019 daemon.info dnsmasq-dhcp[23696]: DHCPACK(br-lan) 192.168.1.110 50:67:f0:69:2a:cc nsa310
Thu Feb 28 21:30:22 2019 daemon.warn odhcpd[1290]: DHCPV6 SOLICIT IA_NA from 000300015067f0692acc on br-lan: ok fded:6849:fba9::110/128
Thu Feb 28 21:30:22 2019 daemon.warn odhcpd[1290]: DHCPV6 SOLICIT IA_PD from 000300015067f0692acc on br-lan: ok fded:6849:fba9:4::/62
Thu Feb 28 21:30:22 2019 daemon.info dnsmasq[23696]: read /etc/hosts - 4 addresses
Thu Feb 28 21:30:22 2019 daemon.info dnsmasq[23696]: read /tmp/hosts/odhcpd - 4 addresses
Thu Feb 28 21:30:22 2019 daemon.info dnsmasq[23696]: read /tmp/hosts/dhcp.cfg01411c - 24 addresses
Thu Feb 28 21:30:22 2019 daemon.info dnsmasq-dhcp[23696]: read /etc/ethers - 0 addresses
Thu Feb 28 21:30:22 2019 daemon.warn odhcpd[1290]: DHCPV6 REQUEST IA_NA from 000300015067f0692acc on br-lan: ok fded:6849:fba9::110/128
Thu Feb 28 21:30:22 2019 daemon.warn odhcpd[1290]: DHCPV6 REQUEST IA_PD from 000300015067f0692acc on br-lan: ok fded:6849:fba9:4::/62
Thu Feb 28 21:30:22 2019 daemon.info dnsmasq[23696]: read /etc/hosts - 4 addresses
Thu Feb 28 21:30:22 2019 daemon.info dnsmasq[23696]: read /tmp/hosts/odhcpd - 5 addresses
Thu Feb 28 21:30:22 2019 daemon.info dnsmasq[23696]: read /tmp/hosts/dhcp.cfg01411c - 24 addresses
Thu Feb 28 21:30:22 2019 daemon.info dnsmasq-dhcp[23696]: read /etc/ethers - 0 addresses
Thu Feb 28 21:30:44 2019 kern.info kernel: [171931.437756] mtk_soc_eth 1e100000.ethernet eth0: port 2 link down


root@OpenWrt:/# ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Full
        Link partner advertised pause frame use: Symmetric
        Link partner advertised auto-negotiation: Yes
        Link partner advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes
root@OpenWrt:/# ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Full
        Link partner advertised pause frame use: Symmetric
        Link partner advertised auto-negotiation: Yes
        Link partner advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes
root@OpenWrt:/# ifconfig
br-lan    Link encap:Ethernet  HWaddr 50:67:F0:69:2A:CC
          inet addr:192.168.1.110  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::5267:f0ff:fe69:2acc/64 Scope:Link
          inet6 addr: fded:6849:fba9::5267:f0ff:fe69:2acc/64 Scope:Global
          inet6 addr: fded:6849:fba9::110/128 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5111 errors:0 dropped:0 overruns:0 frame:0
          TX packets:598 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1225692 (1.1 MiB)  TX bytes:45118 (44.0 KiB)

eth0      Link encap:Ethernet  HWaddr 50:67:F0:69:2A:CC
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5297 errors:0 dropped:0 overruns:0 frame:0
          TX packets:598 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1309522 (1.2 MiB)  TX bytes:45118 (44.0 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:232 errors:0 dropped:0 overruns:0 frame:0
          TX packets:232 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:19390 (18.9 KiB)  TX bytes:19390 (18.9 KiB)

root@OpenWrt:/# ping wp.pl
PING wp.pl (212.77.98.9): 56 data bytes
64 bytes from 212.77.98.9: seq=0 ttl=60 time=9.122 ms
64 bytes from 212.77.98.9: seq=1 ttl=60 time=8.332 ms
root@OpenWrt:/# opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade
Upgrading opkg on root from 2017-12-07-3b417b9f-2 to 2019-01-18-7708a01a-1...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_xscale/base/opkg_2019-01-18-7708a01a-1_arm_xscale.ipk
Upgrading ubus on root from 2018-07-26-40e0931e-1 to 2018-10-06-221ce7e7-1...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_xscale/base/ubus_2018-10-06-221ce7e7-1_arm_xscale.ipk
Upgrading rpcd on root from 2018-08-16-41333abe-1 to 2018-11-28-3aa81d0d-1...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_xscale/base/rpcd_2018-11-28-3aa81d0d-1_arm_xscale.ipk
Upgrading busybox on root from 1.28.3-4 to 1.28.4-2...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_xscale/base/busybox_1.28.4-2_arm_xscale.ipk
Upgrading luci-lib-ip on root from git-18.228.31946-f64b152-1 to git-19.051.55698-76cf653-1...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_xscale/luci/luci-lib-ip_git-19.051.55698-76cf653-1_arm_xscale.ipk
Upgrading libubus-lua on root from 2018-07-26-40e0931e-1 to 2018-10-06-221ce7e7-1...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_xscale/base/libubus-lua_2018-10-06-221ce7e7-1_arm_xscale.ipk
Upgrading luci-theme-bootstrap on root from git-18.228.31946-f64b152-1 to git-19.051.55698-76cf653-1...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_xscale/luci/luci-theme-bootstrap_git-19.051.55698-76cf653-1_all.ipk
Upgrading netifd on root from 2018-07-30-a0a1e52e-1 to 2019-01-31-a2aba5c7-2.1...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_xscale/base/netifd_2019-01-31-a2aba5c7-2.1_arm_xscale.ipk
[ 3914.059017] br-lan: port 1(eth0) entered disabled state
[ 3914.085584] device eth0 left promiscuous mode
[ 3914.090041] br-lan: port 1(eth0) entered disabled state
[ 3914.133247] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Upgrading ubusd on root from 2018-07-26-40e0931e-1 to 2018-10-06-221ce7e7-1...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_xscale/base/ubusd_2018-10-06-221ce7e7-1_arm_xscale.ipk
Failed to establish connection
Upgrading firewall on root from 2018-07-26-aa8846bb-1 to 2018-08-13-1c4d5bcd-1...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_xscale/base/firewall_2018-08-13-1c4d5bcd-1_arm_xscale.ipk
Failed to establish connection
Upgrading luci-app-firewall on root from git-18.228.31946-f64b152-1 to git-19.051.55698-76cf653-1...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_xscale/luci/luci-app-firewall_git-19.051.55698-76cf653-1_all.ipk
Failed to establish connection
Upgrading odhcp6c on root from 2018-07-14-67ae6a71-14 to 2018-07-14-67ae6a71-15...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_xscale/base/odhcp6c_2018-07-14-67ae6a71-15_arm_xscale.ipk
Failed to establish connection
Upgrading uclient-fetch on root from 2018-08-03-ae1c656f-1 to 2018-11-24-3ba74ebc-1...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_xscale/base/uclient-fetch_2018-11-24-3ba74ebc-1_arm_xscale.ipk
Failed to establish connection
Upgrading libuclient on root from 2018-08-03-ae1c656f-1 to 2018-11-24-3ba74ebc-1...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_xscale/base/libuclient_2018-11-24-3ba74ebc-1_arm_xscale.ipk
Failed to establish connection
Upgrading dropbear on root from 2017.75-5 to 2017.75-7.1...
Downloading http://downloads.openwrt.org/releases/18.06.1/packages/arm_xscale/base/dropbear_2017.75-7.1_arm_xscale.ipk
^CInterrupted. Writing out status database.

root@OpenWrt:/# Failed to establish connection

root@OpenWrt:/# ping wp.pl




Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 10 kwie 2019, 12:09 
Offline
Użytkownik

Rejestracja: 17 lis 2011, 10:51
Posty: 285
Mam problem z połączeniem ftp vsftpd.

Status: Łączenie z xxx.xxx.xxx.xxx:21...
Status: Połączenie nawiązanie, oczekiwanie na wiadomość powitalną...
Status: Inicjowanie TLS...
Status: Weryfikacja certyfikatu...
Status: Połączenie TLS nawiązane.
Status: Zalogowany
Status: Uzyskiwanie listy katalogów...
Polecenie: PWD
Odpowiedź 257 "/root" is the current directory
Polecenie: TYPE I
Odpowiedź 200 Switching to Binary mode.
Polecenie: PASV
Odpowiedź 227 Entering Passive Mode (xxx,xxx,xxx,xxx,125,96).
Polecenie: LIST
Błąd: Połączenie danych nie mogło zostać nawiązane: ECONNREFUSED - Połączenie odmówione przez serwer

Passive włączony i porty odblokowane. Gdzie szukać problemu?

EDIT:

Zdaje się, że blokowane na poziomie obecnej sieci. W innej działa bez problemu.


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat Odpowiedz w temacie  [ Posty: 1928 ]  Przejdź na stronę Poprzednia  1 ... 93, 94, 95, 96, 97

Strefa czasowa UTC+1godz. [letni]


Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 4 gości


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów

Szukaj:
Przejdź do:  
cron
designed by digi-led.pl
...Copyright © 2010-2013, Ekipa openrouter.info