Dzisiaj jest 27 cze 2017, 14:23

Strefa czasowa UTC+1godz. [letni]




Nowy temat Odpowiedz w temacie  [ Posty: 67 ]  Przejdź na stronę Poprzednia  1, 2, 3, 4  Następna
Autor Wiadomość
 Tytuł: Re: Xiaomi Mi WiFi
Post: 5 maja 2014, 15:53 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 12855
Lokalizacja: Warszawa
Ha! A ty skąd wiesz co tam siedzi? Masz boolog z niego?

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 5 maja 2014, 15:58 
Offline
Użytkownik
Awatar użytkownika

Rejestracja: 12 lut 2012, 22:24
Posty: 2034
Lokalizacja: Warszawa
obsy pisze:
Ha! A ty skąd wiesz co tam siedzi? Masz boolog z niego?

Fizycznie miałem go dosłownie chwilę i pojechał do klienta... postaram się załatwić na dłużej, to się pobawimy! :D

_________________
Modyfikacja U-Boot dla routerów (gotowe obrazy)
Overclocking ZyXEL NSA310

Podejmę się naprawy każdego routera, wymienię RAM i FLASH na większy


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 6 maja 2014, 00:36 
Offline
Użytkownik

Rejestracja: 16 sie 2012, 05:14
Posty: 708
No to się jeszcze "nie odkręcam"...poczekamy co pepe napisze, czy ktoś co to "dotknie głębiej" ;)


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 6 maja 2014, 06:55 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 12855
Lokalizacja: Warszawa
Przedstawia się toto jako Attitude Adjustemnt 12.09.1, dokładnie r40423. Choć widać że popracowali, bo kernel to 2.6.36.4, całość jest architekturą brcm4709.
Interfejs jest w luci, posiada także własną stronę mobilną. System ma i ntfs i exfata (jakoś z licencji nie robią sobie problemów :)), Bluetooth, dość dużo autorskich przeróbek i rozwiązań (sądząc po ilości zmodyfikowanych plików). Wifi to broadcom, są narzędzia typu nas ale i kwiatki typu nvram.
Wentylator jest kontrolowany przez PWM, jest tools do sterowania jego obrotami.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 6 maja 2014, 09:22 
Offline
Użytkownik
Awatar użytkownika

Rejestracja: 12 lut 2012, 22:24
Posty: 2034
Lokalizacja: Warszawa
obsy pisze:
Wentylator jest kontrolowany przez PWM, jest tools do sterowania jego obrotami.

W praktyce ten wentylator, to nie wentylator... tam jest taka mała, wk...ca turbina :)

_________________
Modyfikacja U-Boot dla routerów (gotowe obrazy)
Overclocking ZyXEL NSA310

Podejmę się naprawy każdego routera, wymienię RAM i FLASH na większy


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 6 maja 2014, 09:26 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 12855
Lokalizacja: Warszawa
Więc będzie można na nim melodyki robić :)

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 6 maja 2014, 17:50 
Offline
Użytkownik

Rejestracja: 16 sie 2012, 05:14
Posty: 708
Czyli to tak wygląda jakby można zrobić i zwykły port, na zwykłe openwrt (to pewno i dd-wrt), jak również i tomato. Takie wszystko w jednym - ciekawe.
He - openwrt to może i gargoyle ?
;) :D


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 6 cze 2014, 23:23 
Offline
Użytkownik

Rejestracja: 12 lis 2011, 18:48
Posty: 67
no w końcu widzę sprzęt dla mnie, niecierpliwie czekam na testy, dużo nie wymagam transfery po sambie, ftp transmision, przytuliłbym taki kombajn, bo z zakupem wndr4700 nie wyszło, szukam router i nas w jednym


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 3 lip 2014, 20:44 
Offline
Użytkownik

Rejestracja: 12 lis 2011, 18:48
Posty: 67
Witam zakupiłem u Chińczyków ten router za 576zł: kilka fotek poniżej:
Obrazek
Obrazek
Obrazek
Obrazek
Obrazek

sprzęt przyszedł od razu skręcony (więc zabawa w skręcanie odchodzi), wyposażony w dysk 1Tb, obawiałem się wiatraczka ale działa bardzo cicho, obudowa wydaje się zrobiona z solidnego plastiku, w pudełku otrzymujemy router i zasilacz, brak kabla sieciowego, uruchomieniu świeci jedna dioda koloru niebieskiego, router działa bardzo stabilnie nie gubi połączeń, wifi bardzo stabilne zasięg i moc lepsza jak na wndr3700v2. Po wgraniu wersji rozwojowej oprogramowania mamy dostęp do ssh i możliwość wgrywania pakietów z czystego openwrt, jednak mimo chińskich turtoriali nie udało mi się uruchomić transmission czy proftpd, tak więc sprzęt ląduje w dziale giełda używany tylko kilka dni, zasilacz nie odpakowany gdyż ten sam amperaż i wtyczkę posiada wndr3700v2. Menu całe po chińsku ale producenci użyli prostych określeń także google translator bez problemu tłumaczy na Polski i nie ma problemu z konfiguracją w luci, z tego co czytałem na forum niebawem ma wyjść wersja angielska oprogramowania bo planują wyjść z tym sprzętem poza chiński rynek. Jak chcecie jakieś testy to piszcie tylko dokładnie co i jak wykonać bo za bardzo nie ogarniam.


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 4 lip 2014, 05:05 
Offline
Użytkownik

Rejestracja: 16 sie 2012, 05:14
Posty: 708
Byłem w pierwszym odruchu napalony na ten sprzęt, więc dopytam o kilka detali.
1. Testy transferów WAN->LAN (jak nie masz szybkiego internetu, np. UPC 250 może jakoś symulując, że na WAN będzie inny router, który puszcza na swoim złączu LAN coś solidnie po ftp, i.t.d.)
2. Faktyczne osiągi na złączu sata - jak kuma dysk ? - skoro jest dostęp do oprogramowania przez ssh to może chociaż uda się wykonać po doinstalowaniu/użyciu "hdparm -t -T /dev/sd*", gdzie gwiazdka to litera tego dysku 1 TB)
3. Jakieś wyniki ze smartctl by ogarnąć więcej szczegółów o samym dysku
4. Czy jest jakiś dostęp do RS-a ? - jak tak, to jakiś bootlog mile widziany.
5. Więcej info o samej, jak to nazwałeś, rozwojowej wersji firmware - co da się zainstalować, jak to zrobione w porównaniu z istniejącą oryginalną rewizją openwrt - co wyjęte, co zmienione...po prostu więcej info o sofcie.
6. Więcej szczegółów o rzekomym WIFI-AC - jakie osiągi transferów, zasięgi, i.t.d. Jakie sterowniki ?
7. Co powoduje, że nie możesz zainstalować transmission - jakieś zależności niespełnione, i.t.d. ?


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 8 lip 2014, 18:17 
Offline
Użytkownik

Rejestracja: 12 lis 2011, 18:48
Posty: 67
testów wlan ci nie zrobię bo nie umie, transfer z dysku po wifi 5ghz leci 20mb/s na wndr3700v2 miałem jakieś 8-10mb/s, hdparm mimo instalacji nie chce odpalić (komunikat not found, mimo że jak listuję opkg to pokazuje ze zainstalowany) ale chińczyki widziałem że odpalają to bez problemu, transfer po lanie; ściąganie pliku z routera 55mb/s, wysyłanie 25mb/s z tym że nie mam załączonego jumbo frame bo oprogramowanie tego nie obsługuje, odnośnie oprogramowania to są dwie wersje rozwojowa (wydawane cotygodniowe aktualizacje) i stabilne wydawane raz na jakiś czas, transmision i vsftpd, zainstalowałem dzięki chinczykom (duże wsparcie na forum i sporo ludzi chętnych do roboty z autorskimi kompilacjami łatwymi do instalacji), także oferta sprzedaży już nie aktualna sprzęt sobie zostawiam, za to po młotek idzie wndr3700v2 i zyxel nsa310, z tego co wyczytałem to ma być niedługo angielskojęzyczna wersja oprogramowania i więcej programów w oprogramowaniu routera (np ostatnio dodali ddns), jak ktoś chętny do dłubania to zachęcam do zakupu maszynka ma spore możliwości a zanim netgear czy dlink coś takiego wypuści to miną wieki bo im się to po prostu nie opłaca, wolą sprzedawać osobno nas i router a wndr4700 olali totalnie, osoby bardziej ogarnięte w temacie openwrt bez problemu postawiły by czyste openwrt choć w zasadzie nie ma sensu bo nawet fabryczna wersja oprogramowania jest otwarta na instalacje pakietów ze źródeł openwrt, tylko trzeba ogarnąć zależności i uprawnienia


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 8 lip 2014, 19:54 
Offline
Użytkownik

Rejestracja: 16 sie 2012, 05:14
Posty: 708
He...to jednak dobrze, że napisałem te wszystkie moje pytania (przy okazji dzięki za część odpowiedzi) bo router został i będziesz go dalej badał/używał/testował/i.t.d. (przy okazji co jakiś czas, o jakiejś istotnej zmianie, progsach, i.t.d. z praktyki - nie zawadziłoby gdybyś zamieścił kilka słów w kolejnym poście, w tym wątku/temacie).
I znów się łamię - kupić czy nie kupić - na nowo...:D


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 8 lip 2014, 20:26 
Offline
Użytkownik

Rejestracja: 12 lis 2011, 18:48
Posty: 67
kupuj bedzie nas dwóch a podejrzewam ze ty dałbyś radę opanować czyste openwrt i byłoby git, nie będzie chińczyk pluł nam w twarz ;)


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 8 lip 2014, 23:05 
Offline
Użytkownik

Rejestracja: 12 lis 2011, 18:48
Posty: 67
co trzeba dodać aby załączyć jumbo frame
etc/config/network wyglada u mnie tak

config switch 'eth0'
option enable '1'

config switch_vlan 'eth0_1'
option device 'eth0'
option vlan '1'
option ports '0 2 5*'

config switch_vlan 'eth0_2'
option device 'eth0'
option vlan '2'
option ports '4 5'

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.31.1'
option netmask '255.255.255.0'

config interface 'wan'
option proto 'dhcp'
option ifname 'eth0.2'

i jeszcze pytanko odnośnie samby, do routera jest dostępny program do zainstalowania w którym trzeba się zalogować i uzyskuje się dostęp do samby, ale pomyślałem że nie chce tego chinskiego szajsu i chciałbym dodać normalnie lokalizacje sieciową lecz komp bez tego progsa nie wykrywa w ogóle routera, pewnie coś z configiem samby który wygląda tak co zrobić aby działało to normalnie

config samba
option 'name' 'druk'
option 'workgroup' 'WORKGROUP'
option 'description' 'Share from router'
option 'homes' '1'

config 'sambashare'
option 'read_only' 'no'
option 'create_mask' '0777'
option 'dir_mask' '0777'
option 'name' 'XiaoMi'
option 'path' '/userdisk/data'
option 'guest_ok' 'yes'
option 'force_user' 'root'
option 'privacy' 'no'
option 'browseable' 'yes'

config 'sambashare'
option 'read_only' 'no'
option 'create_mask' '0777'
option 'dir_mask' '0777'
option 'name' 'XiaoMi(Privacy)'
option 'path' '/userdisk/privacyData'
option 'guest_ok' 'yes'
option 'force_user' 'root'
option 'privacy' 'yes'
option 'browseable' 'no'

config 'sambashare'
option 'read_only' 'no'
option 'create_mask' '0777'
option 'dir_mask' '0777'
option 'name' 'XiaoMi-usb0'
option 'path' '/extdisks/sdb1'
option 'guest_ok' 'yes'
option 'force_user' 'root'
option 'privacy' 'no'
option 'browseable' 'yes'


samba.conf.template

[global]
netbios name = |NAME|
display charset = |CHARSET|
interfaces = br-lan
bind interfaces only = yes
server string = |DESCRIPTION|
unix charset = |CHARSET|
workgroup = |WORKGROUP|
browseable = yes
deadtime = 30
domain master = yes
encrypt passwords = true
enable core files = no
guest account = nobody
guest ok = yes
invalid users =
local master = yes
load printers = no
map to guest = Bad User
max protocol = SMB2
min receivefile size = 16384
null passwords = yes
obey pam restrictions = yes
os level = 20
passdb backend = smbpasswd
preferred master = yes
printable = no
security = share
smb encrypt = disabled
smb passwd file = /etc/samba/smbpasswd
socket options = TCP_NODELAY IPTOS_LOWDELAY
syslog = 1
use sendfile = yes
writeable = yes
log level = 1
max log size = 500
log file = /tmp/log/samba.log


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 8 lip 2014, 23:08 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 12855
Lokalizacja: Warszawa
W jakim urządzeniu chcesz te jumbo?

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 8 lip 2014, 23:19 
Offline
Użytkownik

Rejestracja: 12 lis 2011, 18:48
Posty: 67
w switchu bo po stronie wan nie ma sensu, a sprzet to mi wifi router z tematu


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 8 lip 2014, 23:25 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 12855
Lokalizacja: Warszawa
Taka opcja musi być zapewniona przez sterownik. Tak "samej z siebie" to żadnej takiej opcji nie ma.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 8 lip 2014, 23:29 
Offline
Użytkownik

Rejestracja: 12 lis 2011, 18:48
Posty: 67
jak sprawdzić czy sterownik obsługuje ? czy można coś tam wklepać i sprawdzić czy działa czy coś może się posypac jeśli sterownik nie obsługuje tej funkcji


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 8 lip 2014, 23:40 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 12855
Lokalizacja: Warszawa
Przepuść ramki po 9k. Jak nie zdefragmentuje/zgubi pakietu to może działać.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: Xiaomi Mi WiFi
Post: 9 lip 2014, 00:00 
Offline
Użytkownik

Rejestracja: 12 lis 2011, 18:48
Posty: 67
nie niestety 100% zgubionych pakietów, a sambą ktoś pomoże??


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat Odpowiedz w temacie  [ Posty: 67 ]  Przejdź na stronę Poprzednia  1, 2, 3, 4  Następna

Strefa czasowa UTC+1godz. [letni]


Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów

Szukaj:
Przejdź do:  
designed by digi-led.pl
...Copyright © 2010-2013, Ekipa openrouter.info