Dzisiaj jest 23 wrz 2017, 05:53

Strefa czasowa UTC+1godz. [letni]




Nowy temat Odpowiedz w temacie  [ Posty: 60 ]  Przejdź na stronę Poprzednia  1, 2, 3  Następna
Autor Wiadomość
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 21 kwie 2012, 18:13 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 12920
Lokalizacja: Warszawa
-p tcp jeszcze dodaj.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 21 kwie 2012, 19:01 
Offline
Użytkownik

Rejestracja: 8 lut 2012, 09:25
Posty: 133
To samo

Cytuj:
iptables -I FORWARD -s 10.10.10.0/24 -d 192.168.1.1 --dport 9100 -p tcp -j ACCEPT
iptables v1.4.6: unknown option `--dport'


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 21 kwie 2012, 19:02 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 12920
Lokalizacja: Warszawa
Kolejność ma znaczenie.

iptables -I FORWARD -p tcp -s 10.10.10.0/24 -d 192.168.1.1 --dport 9100 -j ACCEPT

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 21 kwie 2012, 19:13 
Offline
Użytkownik

Rejestracja: 8 lut 2012, 09:25
Posty: 133
teraz dziala ;)

A czemu nie dziala w tej postaci:

Cytuj:
uci add firewall forwarding
uci set firewall.@forwarding[-1].proto=tcp
uci set firewall.@forwarding[-1].src=10.10.10.0/24
uci set firewall.@forwarding[-1].dest=192.168.1.1
uci set firewall.@forwarding[-1].dest_port=9100
uci set firewall.@forwarding[-1].target=ACCEPT


Cytuj:
root@router:~$ uci add firewall forwarding
cfg20ad58
root@router:~$ uci set firewall.@forwarding[-1].proto=tcp
root@router:~$ uci set firewall.@forwarding[-1].src=10.10.10.0/24
root@router:~$ uci set firewall.@forwarding[-1].dest=192.168.1.1
root@router:~$ uci set firewall.@forwarding[-1].dest_port=9100
root@router:~$ uci set firewall.@forwarding[-1].target=ACCEPT
root@router:~$
root@router:~$ uci commit firewall
root@router:~$
root@router:~$ /etc/init.d/firewall restart
iptables: Too many links.
Loading defaults
Loading synflood protection
Adding custom chains
Loading zones
iptables: Chain already exists.
Loading forwardings
iptables v1.4.6: Couldn't load target `zone_192.168.1.1_ACCEPT':File not found

Try `iptables -h' or 'iptables --help' for more information.
Loading redirects
Loading rules
Loading includes
Optimizing conntrack
Loading interfaces
root@router:~$


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 21 kwie 2012, 19:16 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 12920
Lokalizacja: Warszawa
Bo masz błąd jeżeli tego nie zauważyłeś. Forwarding nie ma takich opcji: http://wiki.openwrt.org/doc/uci/firewall#forwardings

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 21 kwie 2012, 22:36 
Offline
Użytkownik

Rejestracja: 8 lut 2012, 09:25
Posty: 133
Dzieki Ci wielkie, tego linku potrzebowalem ;)

Teraz dziala:

Cytuj:
uci add firewall rule
uci set firewall.@rule[-1].src=guest
uci set firewall.@rule[-1].src_ip=10.10.10.0/24
uci set firewall.@rule[-1].proto=tcp
uci set firewall.@rule[-1].dest_ip=192.168.1.1
uci set firewall.@rule[-1].dest_port=9100
uci set firewall.@rule[-1].target=ACCEPT
uci set firewall.@rule[-1].family=ipv4


----- Dodano ----- 21 kwie 2012, o 20:33 -----

cos tu nie gra, myslalem ze juz wiem jak odblokowac inny adres ale, robiac w ten sam sposob inny adres juz nie dziala :/

Na 192.168.1.4 mam serwer FTP i chce zeby byl dosteny z sieci dla goscie, wiec robie:

Cytuj:
uci add firewall rule
uci set firewall.@rule[-1].src=guest
uci set firewall.@rule[-1].src_ip=10.10.10.0/24
uci set firewall.@rule[-1].dest_ip=192.168.1.4
uci set firewall.@rule[-1].target=ACCEPT

uci commit firewall

/etc/init.d/firewall restart


probowalem tez

Cytuj:
uci add firewall rule
uci set firewall.@rule[-1].src=guest
uci set firewall.@rule[-1].src_ip=10.10.10.0/24
uci set firewall.@rule[-1].dest_ip=192.168.1.4
uci set firewall.@rule[-1].dest_port=21
uci set firewall.@rule[-1].target=ACCEPT

uci commit firewall

/etc/init.d/firewall restart


ale to nie dziala :/

----- Dodano ----- 21 kwie 2012, o 22:36 -----

Dobra juz dziala ;) brakowalo:

Cytuj:
option 'dest' 'lan'


Ale jeszcze cos nie daje mi spokoju.

Drukarka USB podpieta do routera, dziala przy takiej regule:

Cytuj:
uci add firewall rule
uci set firewall.@rule[-1].src=guest
uci set firewall.@rule[-1].src_ip=10.10.10.0/24
uci set firewall.@rule[-1].proto=tcpudp
uci set firewall.@rule[-1].dest_ip=192.168.1.1
uci set firewall.@rule[-1].dest_port=9100
uci set firewall.@rule[-1].target=ACCEPT
uci set firewall.@rule[-1].family=ipv4


Natomiast drukarka z wbudowana karta sieciowa (przypisany adres 192.168.1.2) podlaczona przez LAN nie USB dziala tylko przy takiej regule:

Cytuj:
uci add firewall rule
uci set firewall.@rule[-1].src=guest
uci set firewall.@rule[-1].src_ip=10.10.10.0/24
uci set firewall.@rule[-1].proto=tcpudp
uci set firewall.@rule[-1].dest=lan
uci set firewall.@rule[-1].dest_ip=192.168.1.2
uci set firewall.@rule[-1].dest_port=9100
uci set firewall.@rule[-1].target=ACCEPT
uci set firewall.@rule[-1].family=ipv4


Nie rozumiem dlaczego drukarka usb (printserver na routerze 192.168.1.1 port 9100) nie potrzebuje wpisu:

Cytuj:
uci set firewall.@rule[-1].dest=lan


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 30 kwie 2012, 14:02 
Offline
Użytkownik

Rejestracja: 30 kwie 2012, 13:49
Posty: 3
Sprzęt, to TP-LINK TL-WR1043ND z extroot. Po ustawieniu sieci "dla gości" pojawił się u mnie problem. Po połączeniu do sieci "normalnej" (sieć "lan") wszystko jest ok, po połączeniu do sieci "dla gości" (sieć "guest") połączenie jest po kilkunastu sekundach zrywane. Przez te parę chwil wszystko działa ok. Jeśli ustawię połączenie na kliencie, żeby łączył się automatycznie do sieci dla gości, to co chwilę łączy się i rozłącza. Dzieje się tak niezależnie od sprzętu, który próbuje się podłączyć (sprawdzane na kilku komputerach i telefonie z wifi). Próbowałem przestawiać sieć tylko w tryb bg ale nic to nie daje.

Cytuj:
Apr 30 13:43:05 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: authenticated
Apr 30 13:43:05 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: associated (aid 1)
Apr 30 13:43:05 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 RADIUS: starting accounting session 4F9DAD45-00000000
Apr 30 13:43:05 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 WPA: pairwise key handshake completed (RSN)
Apr 30 13:43:06 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: disassociated
Apr 30 13:43:06 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: authenticated
Apr 30 13:43:06 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: associated (aid 1)
Apr 30 13:43:06 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 RADIUS: starting accounting session 4F9DAD45-00000001
Apr 30 13:43:06 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 WPA: pairwise key handshake completed (RSN)
Apr 30 13:43:08 Gargoyle daemon.info dnsmasq-dhcp[4511]: DHCPDISCOVER(wlan0-1) 0.0.0.0 78:ca:04:6c:6b:73
Apr 30 13:43:08 Gargoyle daemon.info dnsmasq-dhcp[4511]: DHCPOFFER(wlan0-1) 10.1.1.153 78:ca:04:6c:6b:73
Apr 30 13:43:08 Gargoyle daemon.info dnsmasq-dhcp[4511]: DHCPDISCOVER(wlan0-1) 0.0.0.0 78:ca:04:6c:6b:73
Apr 30 13:43:08 Gargoyle daemon.info dnsmasq-dhcp[4511]: DHCPOFFER(wlan0-1) 10.1.1.153 78:ca:04:6c:6b:73
Apr 30 13:43:08 Gargoyle daemon.info dnsmasq-dhcp[4511]: DHCPREQUEST(wlan0-1) 10.1.1.153 78:ca:04:6c:6b:73
Apr 30 13:43:08 Gargoyle daemon.info dnsmasq-dhcp[4511]: DHCPACK(wlan0-1) 10.1.1.153 78:ca:04:6c:6b:73
Apr 30 13:43:08 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: disassociated
Apr 30 13:43:08 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: authenticated
Apr 30 13:43:08 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: associated (aid 1)
Apr 30 13:43:08 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 RADIUS: starting accounting session 4F9DAD45-00000002
Apr 30 13:43:08 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 WPA: pairwise key handshake completed (RSN)
Apr 30 13:43:10 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: disassociated
Apr 30 13:43:10 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: authenticated
Apr 30 13:43:10 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: associated (aid 1)
Apr 30 13:43:10 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 RADIUS: starting accounting session 4F9DAD45-00000003
Apr 30 13:43:10 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 WPA: pairwise key handshake completed (RSN)
Apr 30 13:43:11 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: disassociated
Apr 30 13:43:11 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: authenticated
Apr 30 13:43:11 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: associated (aid 1)
Apr 30 13:43:11 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 RADIUS: starting accounting session 4F9DAD45-00000004
Apr 30 13:43:11 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 WPA: pairwise key handshake completed (RSN)
Apr 30 13:43:13 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: disassociated
Apr 30 13:43:13 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: authenticated
Apr 30 13:43:13 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: associated (aid 1)
Apr 30 13:43:13 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 RADIUS: starting accounting session 4F9DAD45-00000005
Apr 30 13:43:13 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 WPA: pairwise key handshake completed (RSN)
Apr 30 13:43:14 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: disassociated
Apr 30 13:43:14 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: authenticated
Apr 30 13:43:14 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: associated (aid 1)
Apr 30 13:43:14 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 RADIUS: starting accounting session 4F9DAD45-00000006
Apr 30 13:43:14 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 WPA: pairwise key handshake completed (RSN)
Apr 30 13:43:16 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: disassociated
Apr 30 13:43:16 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: authenticated
Apr 30 13:43:16 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: associated (aid 1)
Apr 30 13:43:16 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 RADIUS: starting accounting session 4F9DAD45-00000007
Apr 30 13:43:16 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 WPA: pairwise key handshake completed (RSN)
Apr 30 13:43:18 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: disassociated
Apr 30 13:43:18 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: authenticated
Apr 30 13:43:18 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: associated (aid 1)
Apr 30 13:43:18 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 RADIUS: starting accounting session 4F9DAD45-00000008
Apr 30 13:43:18 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 WPA: pairwise key handshake completed (RSN)
Apr 30 13:43:19 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: disassociated
Apr 30 13:43:19 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: authenticated
Apr 30 13:43:19 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: associated (aid 1)
Apr 30 13:43:19 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 RADIUS: starting accounting session 4F9DAD45-00000009
Apr 30 13:43:19 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 WPA: pairwise key handshake completed (RSN)
Apr 30 13:43:21 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: disassociated

[... wycięte dużo, dużo takich logów...]

Apr 30 13:43:55 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: authenticated
Apr 30 13:43:55 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: associated (aid 1)
Apr 30 13:43:55 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 RADIUS: starting accounting session 4F9DAD45-0000001E
Apr 30 13:43:55 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 WPA: pairwise key handshake completed (RSN)
Apr 30 13:43:56 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: disassociated
Apr 30 13:43:56 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: authenticated
Apr 30 13:43:56 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 IEEE 802.11: associated (aid 1)
Apr 30 13:43:56 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 RADIUS: starting accounting session 4F9DAD45-0000001F
Apr 30 13:43:56 Gargoyle daemon.info hostapd: wlan0-1: STA 78:ca:04:6c:6b:73 WPA: pairwise key handshake completed (RSN)
Apr 30 13:43:57 Gargoyle daemon.info dnsmasq-dhcp[4511]: DHCPRELEASE(wlan0-1) 10.1.1.153 78:ca:04:6c:6b:73


Dla odmiany logi z połączenia tego samego klienta z siecią normalną (lan) wyglądają tak:
Cytuj:
Apr 30 13:45:32 Gargoyle daemon.info hostapd: wlan0: STA 78:ca:04:6c:6b:73 IEEE 802.11: authenticated
Apr 30 13:45:32 Gargoyle daemon.info hostapd: wlan0: STA 78:ca:04:6c:6b:73 IEEE 802.11: associated (aid 2)
Apr 30 13:45:32 Gargoyle daemon.info hostapd: wlan0: STA 78:ca:04:6c:6b:73 RADIUS: starting accounting session 4F9DAD45-00000004
Apr 30 13:45:32 Gargoyle daemon.info hostapd: wlan0: STA 78:ca:04:6c:6b:73 WPA: pairwise key handshake completed (RSN)
Apr 30 13:45:35 Gargoyle daemon.info dnsmasq-dhcp[4511]: DHCPDISCOVER(br-lan) 0.0.0.0 78:ca:04:6c:6b:73
Apr 30 13:45:35 Gargoyle daemon.info dnsmasq-dhcp[4511]: DHCPOFFER(br-lan) 192.168.88.153 78:ca:04:6c:6b:73
Apr 30 13:45:35 Gargoyle daemon.info dnsmasq-dhcp[4511]: DHCPDISCOVER(br-lan) 0.0.0.0 78:ca:04:6c:6b:73
Apr 30 13:45:35 Gargoyle daemon.info dnsmasq-dhcp[4511]: DHCPOFFER(br-lan) 192.168.88.153 78:ca:04:6c:6b:73
Apr 30 13:45:35 Gargoyle daemon.info dnsmasq-dhcp[4511]: DHCPREQUEST(br-lan) 192.168.88.153 78:ca:04:6c:6b:73
Apr 30 13:45:35 Gargoyle daemon.info dnsmasq-dhcp[4511]: DHCPACK(br-lan) 192.168.88.153 78:ca:04:6c:6b:73
Apr 30 13:46:00 Gargoyle daemon.info dnsmasq-dhcp[4511]: DHCPRELEASE(br-lan) 192.168.88.153 78:ca:04:6c:6b:73
Apr 30 13:46:13 Gargoyle daemon.info hostapd: wlan0: STA 00:0e:2e:42:8f:5e WPA: group key handshake completed (RSN)


uname -a:
Cytuj:
Linux Gargoyle 2.6.32.27 #37 Fri Apr 20 15:59:59 CEST 2012 mips GNU/Linux


Ktoś coś podpowie? :-)

PSz


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 30 kwie 2012, 16:58 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 12920
Lokalizacja: Warszawa
Ustaw kodowanie na sieć gościnną i zobacz.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 3 maja 2012, 21:12 
Offline
Użytkownik

Rejestracja: 30 kwie 2012, 13:49
Posty: 3
Problem jest właśnie z szyfrowaniem WPA.
Mam ustawione tak:

Cytuj:
config 'wifi-device' 'radio0'
option 'type' 'mac80211'
option 'macaddr' 'b0:48:7a:f6:67:7e'
option 'hwmode' '11g'
option 'htmode' 'HT20'
option 'noscan' '1'
option 'country' 'PL'
option 'channel' '1'
list 'ht_capab' 'SHORT-GI-40'
list 'ht_capab' 'DSSS_CCK-40'

config 'wifi-iface' 'ap_g'
option 'device' 'radio0'
option 'mode' 'ap'
option 'network' 'lan'
option 'ssid' 'ssid1'
option 'encryption' 'psk2'
option 'key' '87654321'

config 'wifi-iface' 'guest'
option 'device' 'radio0'
option 'mode' 'ap'
option 'network' 'guest'
option 'ssid' 'ssid2'
option 'encryption' 'psk2'
option 'key' '12345678'


Po wyłączeniu szyfrowania (option 'encryption' 'none') trzyma połączenie bez problemu.
Co więcej! Jeśli w podstawowej sieci wifi 'ap_g' ustawię 'guest' zamiast 'lan', to z tą siecią dzieje się to samo.

PSz


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 4 maja 2012, 07:44 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 12920
Lokalizacja: Warszawa
Więc u Ciebie ma problem z pracą VAP. Kwestia sterowników i nic z tym nie zrobisz żeby po lepszyć ich działanie.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 9 cze 2012, 10:18 
Offline
Użytkownik

Rejestracja: 30 kwie 2012, 13:49
Posty: 3
Od kolegi 'baniaczek' dostałem tego linka:
http://eko.one.pl/forum/viewtopic.php?id=2937
Pomogło i teraz działa bardzo ładnie :-)

Na podstawie prób i testów doszedłem do wniosku, że w pliku /etc/config/network wystarczy dopisać dodatkowo "option 'type' 'bridge'":

Cytuj:
config 'interface' 'guest'
option 'type' 'bridge'
option 'proto' 'static'
option 'ipaddr' '10.1.1.1'
option 'netmask' '255.255.255.0'


Zamiast interfejsu wlan0-1 (w poprzedniej konfiguracji) automatycznie tworzy się br-guest i eth0.3.

PSz


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 9 cze 2012, 10:21 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 12920
Lokalizacja: Warszawa
Bridge jest potrzebny jak interfejs ma się składać z kilku innych (np. jak baniaczek podał nieistniejący eth0.3). Jeżeli jest tylko jeden (wifi0-1) nie ma potrzeby, choć w niczym nie przeszkadza (poza nazwą interfejsu).

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 22 lip 2012, 17:15 
Offline
Użytkownik

Rejestracja: 22 lip 2012, 17:01
Posty: 3
Witam.
Jakiś czas temu zainteresowałem się OpenWrt. Jestem mało Linuxowy. W zasadzie jestem totalnie zmicrosoftyzowany. Ale mnogość zastosowań tego projektu skusiła mnie i zainstalowałem sobie na TL-WR1043ND Linuxa, dograłem gargulca i nawet z extrootem sobie poradziłem. Kilka dni temu postanowiłem zrobić dwa WLANy. Wklepałem(bezmyślnie, naturalnie- no może nie do końca:) dodałem swoją nazwe i szyfrowanie) wszystko co jest napisane w pierwszym poście. I okazało się, że działa! Git! Super! Ekstra! Podłaczyłem telefon i działa. Jednak po około 20 min. "pierwsza" sieć zniknęła. Została tylko ta druga, przejęła pulę adresów tej pierwszej(192.168.1...) i lipa. Nawet do routera można było się z niej dostać. Czy ktoś mógłby mi wyjaśnić co się stało?

_________________
Systemy Alarmowe Poznań, Wielkopolska
Instalacje Elektryczne Poznań, Wielkopolska


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 22 lip 2012, 18:13 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 12920
Lokalizacja: Warszawa
Tego nikt nie dopóki do logów nie zajrzysz. Bo na razie to jest wróżenie z fusów.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 22 lip 2012, 21:45 
Offline
Użytkownik

Rejestracja: 22 lip 2012, 17:01
Posty: 3
Ok, jak się do owych logów dostać w Gargoyle nic nie widze takiego. Więc pewnie jakaś komendą. Jaką zatem?

_________________
Systemy Alarmowe Poznań, Wielkopolska
Instalacje Elektryczne Poznań, Wielkopolska


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 22 lip 2012, 21:55 
Offline
Użytkownik
Awatar użytkownika

Rejestracja: 10 kwie 2010, 22:31
Posty: 225
Lokalizacja: Wrocław
logi nie sa zachowywane wiec musisz to wychwycic na bierzaco gdy sie sytuacja powtorzy.
i wtedy odpalasz konsole (putty) i laczysz sie do routera i wydajesz polecenie logread albo dmseg

_________________
Gdy trwoga to do LOG'a
TP-Link TL-WDR3600 OpenWrt/TP-Link W8970/


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 22 lip 2012, 21:57 
Offline
Użytkownik

Rejestracja: 22 lip 2012, 17:01
Posty: 3
Ok. Powalczę z tym jutro. Dziękuję.

_________________
Systemy Alarmowe Poznań, Wielkopolska
Instalacje Elektryczne Poznań, Wielkopolska


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 31 mar 2013, 23:03 
Offline
Użytkownik

Rejestracja: 29 gru 2010, 15:25
Posty: 13
Próbował ktokolwiek ustawić sieć gościnną w Mikrotik?

_________________
Pozdrawiam, Paweł


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 1 kwie 2013, 07:00 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 12920
Lokalizacja: Warszawa
/interface wireless
add name=vap1 master-interface=wlan1 ssid=NewAp

I masz vap. Dodajesz nową pulę adresową, zrób nowe interfejsy/bridge/firewall i masz.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: [howto] Sieć Wi-Fi "gościnna" dla obcych
Post: 1 kwie 2013, 09:40 
Offline
Użytkownik

Rejestracja: 29 gru 2010, 15:25
Posty: 13
Mam RB2011L chcę na 2 portach LAN (9, 10 - dla tych protów mam utworzony bridge_GOSC) zrobić właśnie sieć prywatna, server dhcp już uruchomiłem. Wszystko działa tylko nie mam pomysłu jak puścić sam internet.
Moje ustawienia:
[admin@MikroTik] > interface print detail
Flags: D - dynamic, X - disabled, R - running, S - slave
 0  R  name="ether1_WAN" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=4074

 1     name="ether2_WAN2" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=4074

 2     name="ether3" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=4074

 3     name="ether4" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=4074

 4     name="ether5" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=4074

 5     name="ether6" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=2028

 6     name="ether7" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=2028

 7     name="ether8" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=2028

 8  R  name="ether9_GOSC" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=2028

 9     name="ether10_GOSC" type="ether" mtu=1500 l2mtu=1598 max-l2mtu=2028

10  R  name="bridge_LAN" type="bridge" mtu=1500 l2mtu=65535

11  R  name="bridge_WAN" type="bridge" mtu=1500 l2mtu=1598

12  R  name="bridge_GOSC" type="bridge" mtu=1500 l2mtu=1598
[admin@MikroTik] > ip address print detail
Flags: X - disabled, I - invalid, D - dynamic
 0 D address=192.168.10.200/24 network=192.168.10.0 interface=bridge_WAN actual-interface=bridge_WAN

 1   address=192.168.66.1/24 network=192.168.66.0 interface=bridge_LAN actual-interface=bridge_LAN

 2   address=192.168.77.1/24 network=192.168.77.0 interface=bridge_GOSC actual-interface=bridge_GOSC
[admin@MikroTik] > ip route print detail
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
 0 ADS  dst-address=0.0.0.0/0 gateway=192.168.10.1 gateway-status=192.168.10.1 reachable via  bridge_WAN distance=1
        scope=30 target-scope=10 vrf-interface=bridge_WAN

 1 ADC  dst-address=192.168.10.0/24 pref-src=192.168.10.200 gateway=bridge_WAN gateway-status=bridge_WAN reachable
        distance=0 scope=10

 2 ADC  dst-address=192.168.66.0/24 pref-src=192.168.66.1 gateway=bridge_LAN gateway-status=bridge_LAN reachable
        distance=0 scope=10

 3 ADC  dst-address=192.168.77.0/24 pref-src=192.168.77.1 gateway=bridge_GOSC gateway-status=bridge_GOSC reachable
        distance=0 scope=10

Mój firewall wygląda tak:
[admin@MikroTik] > ip firewall export           
# jan/02/1970 12:10:46 by RouterOS 5.22
# software id = EPFB-FE90
#
/ip firewall address-list
add address=192.168.66.0/24 disabled=no list=LAN
add address=192.168.77.0/24 disabled=no list=GOSC
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s tcp-close-wait-tim
    tcp-established-timeout=1d tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s tcp-syn-rece
    tcp-syn-sent-timeout=5s tcp-syncookie=no tcp-time-wait-timeout=10s udp-stream-timeout=3m
/ip firewall filter
add action=reject chain=input disabled=yes in-interface=bridge_GOSC reject-with=icmp-network-
    src-address-list=GOSC
add action=accept chain=output disabled=yes out-interface=bridge_GOSC src-address-list=GOSC
add action=reject chain=forward disabled=yes in-interface=bridge_GOSC out-interface=bridge_GOSC
    icmp-network-unreachable src-address-list=GOSC
/ip firewall nat
add action=masquerade chain=srcnat disabled=no
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061 sip-direct-media=yes
set pptp disabled=no

Na ta chwile nie mam komunikacji miedzy hostami. Mogę pingnąć 8.8.8.8, wp.pl już nie mogę pingnąć.
Nie mam pomysłu jak dopisać do firewall ta formułe z przepuszcanie zapytań DNS - chyba tego mi brakuje?

_________________
Pozdrawiam, Paweł


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat Odpowiedz w temacie  [ Posty: 60 ]  Przejdź na stronę Poprzednia  1, 2, 3  Następna

Strefa czasowa UTC+1godz. [letni]


Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 4 gości


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów

Szukaj:
Przejdź do:  
cron
designed by digi-led.pl
...Copyright © 2010-2013, Ekipa openrouter.info