Dzisiaj jest 23 lut 2019, 19:11

Strefa czasowa UTC+1godz. [letni]




Nowy temat Odpowiedz w temacie  [ Posty: 5 ] 
Autor Wiadomość
 Tytuł: OpenVpn Xiaomi Router 3G
Post: 31 sty 2019, 15:35 
Offline
Użytkownik

Rejestracja: 27 paź 2016, 15:00
Posty: 27
Hej,

mam problem z konfiguracją OpenVpn na Xiaomi, mianowicie nie wstaje mi interface tun0.
OpenWrt 18.06.1, r7258-5eb055306f

/etc/config/network
config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config globals 'globals'
   option ula_prefix 'fd13:c447:a46b::/48'

config interface 'lan'
   option type 'bridge'
   option ifname 'eth0.1'
   option proto 'static'
   option ipaddr '192.168.1.1'
   option netmask '255.255.255.0'
   option ip6assign '60'

config device 'lan_dev'
   option name 'eth0.1'
   option macaddr '50:64:2b:ac:cd:c8'

config interface 'wan'
   option ifname 'eth1'
   option proto 'dhcp'

config switch
   option name 'switch0'
   option reset '1'
   option enable_vlan '1'

config switch_vlan
   option device 'switch0'
   option vlan '1'
   option ports '2 3 6t'

config switch_vlan
   option device 'switch0'
   option vlan '2'
   option ports '1 6t'

config interface 'vpn'
   option ifname 'tun0'
   option proto 'none'



/etc/config/firewall
config defaults
   option syn_flood   1
   option input      ACCEPT
   option output      ACCEPT
   option forward      REJECT
# Uncomment this line to disable ipv6 rules
#   option disable_ipv6   1

config zone
   option name      lan
   list   network      'lan'
   option input      ACCEPT
   option output      ACCEPT
   option forward      ACCEPT

config zone
   option name      wan
   list   network      'wan'
   list   network      'wan6'
   option input      REJECT
   option output      ACCEPT
   option forward      REJECT
   option masq      1
   option mtu_fix      1

config forwarding
   option src      lan
   option dest      wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
   option name      Allow-DHCP-Renew
   option src      wan
   option proto      udp
   option dest_port   68
   option target      ACCEPT
   option family      ipv4

# Allow IPv4 ping
config rule
   option name      Allow-Ping
   option src      wan
   option proto      icmp
   option icmp_type   echo-request
   option family      ipv4
   option target      ACCEPT

config rule
   option name      Allow-IGMP
   option src      wan
   option proto      igmp
   option family      ipv4
   option target      ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
   option name      Allow-DHCPv6
   option src      wan
   option proto      udp
   option src_ip      fc00::/6
   option dest_ip      fc00::/6
   option dest_port   546
   option family      ipv6
   option target      ACCEPT

config rule
   option name      Allow-MLD
   option src      wan
   option proto      icmp
   option src_ip      fe80::/10
   list icmp_type      '130/0'
   list icmp_type      '131/0'
   list icmp_type      '132/0'
   list icmp_type      '143/0'
   option family      ipv6
   option target      ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
   option name      Allow-ICMPv6-Input
   option src      wan
   option proto   icmp
   list icmp_type      echo-request
   list icmp_type      echo-reply
   list icmp_type      destination-unreachable
   list icmp_type      packet-too-big
   list icmp_type      time-exceeded
   list icmp_type      bad-header
   list icmp_type      unknown-header-type
   list icmp_type      router-solicitation
   list icmp_type      neighbour-solicitation
   list icmp_type      router-advertisement
   list icmp_type      neighbour-advertisement
   option limit      1000/sec
   option family      ipv6
   option target      ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
   option name      Allow-ICMPv6-Forward
   option src      wan
   option dest      *
   option proto      icmp
   list icmp_type      echo-request
   list icmp_type      echo-reply
   list icmp_type      destination-unreachable
   list icmp_type      packet-too-big
   list icmp_type      time-exceeded
   list icmp_type      bad-header
   list icmp_type      unknown-header-type
   option limit      1000/sec
   option family      ipv6
   option target      ACCEPT

config rule
   option name      Allow-IPSec-ESP
   option src      wan
   option dest      lan
   option proto      esp
   option target      ACCEPT

config rule
   option name      Allow-ISAKMP
   option src      wan
   option dest      lan
   option dest_port   500
   option proto      udp
   option target      ACCEPT

config zone
   option name      vpn
   option input      ACCEPT
   option forward      ACCEPT
   option output      ACCEPT
   list network      'vpn'
   option masq      1

config forwarding
   option src      vpn
   option dest      wan

config forwarding
   option src      lan
   option dest      vpn

config forwarding
   option src      vpn
   option dest      lan

config rule
   option name      OpenVPN
   option target      ACCEPT
   option src      wan
   option proto      udp
   option dest_port   1194

# include a file with users custom iptables rules
config include
   option path /etc/firewall.user



/etc/config/openvpn
config openvpn 'home'
   option enabled '1'
   option verb '9'
   option dev 'tun0'
   option topology 'subnet'
   option port '1194'
   option proto 'udp'
   option server '10.8.0.0 255.255.255.0'
   option ifconfig '10.8.0.1 255.255.255.0'
   option client_to_client '1'
   option compress 'lzo'
   option keepalive '10 120'
   option persist_tun '1'
   option persist_key '1'
   option dh '/etc/openvpn/dh.pem'
#   option tls_crypt '/etc/openvpn/tc.pem'
   option ca '/etc/openvpn/ca.crt'
   option cert '/etc/openvpn/vpnserver.crt'
   option key '/etc/openvpn/vpnserver.key'
   list push 'redirect-gateway def1'
   list push 'route 192.168.1.0 255.255.255.0'
   list push 'dhcp-option DNS 208.67.222.222'
   list push 'dhcp-option DNS 208.67.220.220'
   list push 'dhcp-option DNS 192.168.1.1'
   list push 'compress lzo'
   list push 'persist-tun'
   list push 'persist-key'


#insmod tun0
Failed to find tun0. Maybe it is a built in module ?


#insmod tun
module is already loaded - tun


#modprobe tun0
failed to find a module named tun0


#modprobe tun
tun is already loaded


#ifconfig
br-lan    Link encap:Ethernet  HWaddr 50:64:2B:AC:CD:C8
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fd13:c447:a46b::1/60 Scope:Global
          inet6 addr: fe80::5264:2bff:feac:cdc8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:97678 errors:0 dropped:0 overruns:0 frame:0
          TX packets:163362 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:10119743 (9.6 MiB)  TX bytes:192982297 (184.0 MiB)

eth0      Link encap:Ethernet  HWaddr 50:64:2B:AC:CD:C7
          inet6 addr: fe80::5264:2bff:feac:cdc7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:98977 errors:0 dropped:3 overruns:0 frame:0
          TX packets:163421 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:11989540 (11.4 MiB)  TX bytes:194310669 (185.3 MiB)
          Interrupt:20

eth0.1    Link encap:Ethernet  HWaddr 50:64:2B:AC:CD:C8
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:97689 errors:0 dropped:10 overruns:0 frame:0
          TX packets:163362 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:10120887 (9.6 MiB)  TX bytes:192982297 (184.0 MiB)

eth1      Link encap:Ethernet  HWaddr 0C:5B:8F:27:9A:64
          inet addr:192.168.8.100  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fe80::e5b:8fff:fe27:9a64/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:159251 errors:0 dropped:0 overruns:0 frame:0
          TX packets:87419 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:190162372 (181.3 MiB)  TX bytes:9039024 (8.6 MiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:273 errors:0 dropped:0 overruns:0 frame:0
          TX packets:273 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:21598 (21.0 KiB)  TX bytes:21598 (21.0 KiB)

wlan0     Link encap:Ethernet  HWaddr 50:64:2B:AC:CD:C9
          inet6 addr: fe80::5264:2bff:feac:cdc9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6407 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:1710803 (1.6 MiB)

wlan1     Link encap:Ethernet  HWaddr 50:64:2B:AC:CD:CA
          inet6 addr: fe80::5264:2bff:feac:cdca/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6407 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:1710827 (1.6 MiB)


#dmesg | grep tun
[   12.677365] tun: Universal TUN/TAP device driver, 1.6


#dmesg | grep tun0
BRAK


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: OpenVpn Xiaomi Router 3G
Post: 31 sty 2019, 15:44 
Online
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 13312
Lokalizacja: Warszawa
Żeby był tun to musisz najpierw uruchomić openvpn. tun jako interfejs jest podnoszony przez openvpn. Nie masz tuna to znaczy że openvpn ci nie działa i nie szukaj problemu z interfejsem tun tylko z konfiguracją openvpn.

Logi, logi...

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: OpenVpn Xiaomi Router 3G
Post: 31 sty 2019, 15:52 
Offline
Użytkownik

Rejestracja: 27 paź 2016, 15:00
Posty: 27
zrobione jest
/etc/init.d/openvpn enable
/etc/init.d/openvpn start


ale niestety nie mam pliku /tmp/openvpn.log

w dmesg | grep openvpn pustka
czemu nie startuje na wywołanie i nie wyrzuca błędu przy commit?

opkg list-installed | grep openvpn
openvpn-easy-rsa - 3.0.4-1
openvpn-openssl - 2.4.5-4.2


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: OpenVpn Xiaomi Router 3G
Post: 31 sty 2019, 16:14 
Online
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 13312
Lokalizacja: Warszawa
Ale masz logread a to są logi systemowe.

Dlaczego miałby wyrzucać błąd przy commit jeżeli składniowo konfiguracja jest poprawna? Na wszelki wypadek zrób uci show openvpn i zobacz czy literówki gdzieś nie masz.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: OpenVpn Xiaomi Router 3G
Post: 31 sty 2019, 16:20 
Offline
Użytkownik

Rejestracja: 27 paź 2016, 15:00
Posty: 27
ok, znalazłem błąd, jak zwykle Cezary ma racje: logi, logi, logi....
OpenSSL: error:02001002:lib(2):func(1):reason(2)
OpenSSL: error:2006D080:lib(32):func(109):reason(128)
OpenSSL: error:140AD002:lib(20):func(173):reason(2)
Cannot load certificate file /etc/openvpn/vpnserver.crt

zła nazwa pliku certyfikatu servera w konfiguracji openvpn.
Dzięki Cezary :)


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat Odpowiedz w temacie  [ Posty: 5 ] 

Strefa czasowa UTC+1godz. [letni]


Kto jest online

Użytkownicy przeglądający to forum: obsy i 4 gości


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów

Szukaj:
Przejdź do:  
designed by digi-led.pl
...Copyright © 2010-2013, Ekipa openrouter.info