Dzisiaj jest 29 cze 2017, 14:32

Strefa czasowa UTC+1godz. [letni]




Nowy temat Odpowiedz w temacie  [ Posty: 2 ] 
Autor Wiadomość
 Tytuł: konfiguracja kilku serwerów openvpn na routerze
Post: 23 cze 2017, 12:49 
Offline
Użytkownik

Rejestracja: 27 paź 2016, 15:00
Posty: 14
Czy istnieje możliwość stworzenia kilku serwerów na routerze? próbuje kilka godzin i jakoś nie mogę tego poprawnie ustawić.

network
config interface 'vpn2'
   option ifname 'tun0'
   option proto 'none'

config interface 'vpn3'
   option ifname 'tun1'
   option proto 'none'



firewall
config rule
   option src 'wan'
   option target 'ACCEPT'
   option proto 'udp'
   option dest_port '1195'

config rule
   option src 'wan'
   option target 'ACCEPT'
   option proto 'udp'
   option dest_port '1196'


config zone
   option name 'vpn_1'
   option network 'vpn2 vpn3'
   option input 'ACCEPT'
   option forward 'REJECT'
   option output 'ACCEPT'
   option masq '1'

config forwarding
   option src 'vpn_1'
   option dest 'lan'

config forwarding
   option src 'lan'
   option dest 'vpn_1'

config forwarding
   option src 'vpn_1'
   option dest 'wan'


openvpn
config openvpn 'A'
   option enabled '1'
   option dev 'tun0'
   option port '1195'
   option proto 'udp'
   option log '/tmp/openvpn2.log'
   option verb '3'
   option dh '/etc/openvpn/dh2048.pem'
   option ca '/etc/openvpn/ca.crt'
   option cert '/etc/openvpn/serwer.crt'
   option key '/etc/openvpn/serwer.key'
   option server '10.8.0.0 255.255.255.0'
   option keepalive '10 120'
   option mode 'server'
   option tls_server '1'
   option comp_lzo 'yes'
   list push 'route 192.168.2.0 255.255.255.0'
   list push 'dhcp-option DNS 192.168.2.1'

config openvpn 'B'
   option enabled '1'
   option dev 'tun1'
   option port '1195'
   option proto 'udp'
   option log '/tmp/openvpn3.log'
   option verb '3'
   option dh '/etc/openvpn/dh2048.pem'
   option ca '/etc/openvpn/ca.crt'
   option cert '/etc/openvpn/serwer.crt'
   option key '/etc/openvpn/serwer.key'
   option server '10.9.0.0 255.255.255.0'
   option keepalive '10 120'
   option mode 'server'
   option tls_server '1'
   option comp_lzo 'yes'
   list push 'route 192.168.2.0 255.255.255.0'
   list push 'dhcp-option DNS 192.168.2.1'


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: konfiguracja kilku serwerów openvpn na routerze
Post: 23 cze 2017, 13:13 
Offline
Administrator
Awatar użytkownika

Rejestracja: 10 kwie 2010, 00:28
Posty: 12855
Lokalizacja: Warszawa
Oba musza być na innych portach.

_________________
http://eko.one.pl - prawie wszystko o OpenWrt


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat Odpowiedz w temacie  [ Posty: 2 ] 

Strefa czasowa UTC+1godz. [letni]


Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 4 gości


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów

Szukaj:
Przejdź do:  
designed by digi-led.pl
...Copyright © 2010-2013, Ekipa openrouter.info