Dzisiaj jest 22 lip 2018, 12:26

Strefa czasowa UTC+1godz. [letni]




Nowy temat Odpowiedz w temacie  [ Posty: 1884 ]  Przejdź na stronę Poprzednia  1 ... 88, 89, 90, 91, 92, 93, 94, 95  Następna
Autor Wiadomość
 Tytuł: Re: ZyXEL NSA310
Post: 12 maja 2016, 15:41 
Offline
Użytkownik

Rejestracja: 11 maja 2016, 07:32
Posty: 5
Teraz przeniosłem system na hdd.

Zrobiłem partycje
/dev/sda1           2048   1026047   1024000   500M 83 Linux        (ext2, boot)
/dev/sda2        1026048  11511807  10485760     5G 83 Linux        (ext4, root)
/dev/sda3       11511808  12535807   1024000   500M 82 Linux swap / Solaris
/dev/sda4       12535808 312581807 300046000 143.1G 83 Linux        (ext4, data)

start wygląda tak:
setenv bootargs 'console=ttyS0,115200 root=/dev/sda2 rootdelay=5'
ide reset
ext2load ide 0 0x0800000 /uImage-NSA310s-4.4.0-kirkwood
ext2load ide 0 0x1100000 /uInitrd
bootm 0x0800000 0x1100000

Ustawienie zmiennych:
setenv bootargs 'console=ttyS0,115200 root=/dev/sda2 rootdelay=5'
setenv bootcmd 'ide reset;ext2load ide 0 0x0800000 /uImage-NSA310s-4.4.0-kirkwood;ext2load ide 0 0x1100000 /uInitrd;bootm 0x0800000 0x1100000'


I wszytko lata jak trzeba.


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 13 maja 2016, 12:07 
Offline
Użytkownik

Rejestracja: 30 cze 2013, 18:34
Posty: 54
Debian8 Kernel 4.5.0

Transfery:
ftp upload do 33MB/s
ftp download do 20MB/s
samba download do 18MB/s

Ciekawe że na dysk wrzucam szybciej niż z niego pobieram.

Nie wygląda to najlepiej, wydaje mi się że na Debian Wheezy było jednak lepiej.
Zrobiłem backup systemu do tar. Zastanawiam się nad testami ArchLinuxARM, widziałem posty że tam podobno lepiej ze sterownikami do sieciówki. Dysk WDRed 2TB.


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 13 maja 2016, 12:41 
Offline
Użytkownik

Rejestracja: 21 kwie 2013, 21:16
Posty: 57
Słabo coś Ci to działa. U mnie Jessie, kernel 4.4.6 Debianowy (+ mój konfig - nie potrzebuję wszystkiego): download samba/ftp -> leci ile dysk/eth daje czyli 110MB/s, upload w okolicach 40-45MB/s. Dysk taki sam jak Twój. Swego czasu wrzucałem tu wyniki.
Polecam pobawić się ethtool'em i powłączać liczenie crc przez sieciówkę, można też z ustawieniami samby pokombinować, choć jak masz ftpa wolnego to problem gdzieś indziej. Aha, jak do testów używasz TC to trzeba używać zdecydowanie wersję 64bitową (o ile system 64bitowy).


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 13 maja 2016, 12:50 
Offline
Użytkownik

Rejestracja: 30 cze 2013, 18:34
Posty: 54
No właśnie jest bardzo wolno pamiętam że było zdecydowanie szybciej, przeszukam posty odnośnie ethtool bo przeglądałem niedawno pobieżnie temat i wiem że tam bawiliście się tym. Win7 x64/ TC x64. Zdecydowanie jest coś z siecią nie tak. Technicznie się nic nie zmieniło u mnie w okablowaniu od ostatniego czasu.


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 14 maja 2016, 07:04 
Offline
Użytkownik

Rejestracja: 11 maja 2016, 07:32
Posty: 5
Jak wygląda sprawa z automatycznym uruchamianiem o wybranej porze? Można to ustawić z poziomu systemu?


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 14 maja 2016, 21:36 
Offline
Użytkownik

Rejestracja: 30 cze 2013, 18:34
Posty: 54
Przeszukałem temat i zmodyfikowałem ustawienia karty sieciowej i samba następująco:
/etc/network/interfaces:
post-up /sbin/ethtool -K eth0 tx on gso on sg on tso on tx-nocache-copy on

/etc/samba/smb.conf:
use sendfile = yes
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=131072 SO_SNDBUF=131072
read raw = yes
write raw = yes

Teraz transfery wyglądają następująco:
ftp download ~70MB/s
ftp upload ~35MB/s
samba download ~60MB/s

Po zmianie MTU na NAS i PC spada trochę download ale wzrasta upload.
Wynik polecenia hdparm -tT /dev/sda
/dev/sda:
 Timing cached reads:   554 MB in  2.00 seconds = 276.32 MB/sec
 Timing buffered disk reads: 326 MB in  3.01 seconds = 108.32 MB/sec


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 14 maja 2016, 22:58 
Offline
Użytkownik

Rejestracja: 30 cze 2013, 18:34
Posty: 54
Tworzenie konta użytkownika ftp, konfiguracja vsftpd i dostęp do podmontowanych partycji.

Zawsze miałem jakiś problem z tworzeniem konta użytkownika na potrzeby ftp, lub z prawami użytkownika do folderów na potrzeby ftp. Nie mogłem sobie poradzić z tutorialami dla vsftpd i w końcu stwierdziłem zrezygnowany że przejdę jednak na proftpd i zacząłem szukać pomocy. Trafiłem na poradnik który mi rozjaśnił sytuację HOWTO : Create a FTP server with user access (proftpd) http://ubuntuforums.org/showthread.php?t=79588
Mnie interesował w zasadzie tylko punkt 2.
Po tych zabiegach uruchomiłem vsftpd tak jak chciałem :)
/etc/vsftpd.conf:
listen=YES
listen_port=21
anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=022
anon_upload_enable=NO
anon_mkdir_write_enable=NO
dirmessage_enable=YES
xferlog_enable=YES
xferlog_file=/var/log/vsftpd.log
connect_from_port_20=YES
chown_uploads=YES
chown_username=userftp
chroot_local_user=YES
ftpd_banner=Welcome NAS FTP service.
secure_chroot_dir=/var/run/vsftpd
pam_service_name=vsftpd
tcp_wrappers=YES
local_root=/home

W pliku /etc/fstab za pomocą bind możemy podmontować partycje do folderu użytkownika ftp:
/dev/sda2 /media/nas/music ext4 defaults 0 2
/dev/sda3 /media/nas/foto ext4 defaults 0 2
/dev/sda4 /media/nas/stuff ext4 defaults 0 2
/media/nas/music /home/userftp/nas/music ext4 bind 0 0
/media/nas/foto /home/userftp/nas/foto-movies ext4 bind 0 0
/media/nas/stuff /home/userftp/nas/stuff ext4 bind 0 0


Automatyczne uruchamianie Aria2
Z uruchamianiem Aria2 też kiedyś miałem problem i rozwiązałem to teraz w następujący sposób:
Wpis w /etc/rc.local:
/usr/bin/aria2

Skrypt aria2
/usr/bin/aria2:
#!/bin/sh
aria2c --conf-path=/etc/aria2.conf

/etc/aria2.conf:
daemon=true
enable-rpc=true
rpc-listen-all=true
rpc-allow-origin-all
rpc-secret=token
dir=/home/userftp/nas/#download
log-level=error
log=/tmp/aria.log


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 14 maja 2016, 23:45 
Offline
Użytkownik

Rejestracja: 30 cze 2013, 18:34
Posty: 54
Tworzenie pełnej kopii systemu (w moim przypadku system na partycji sda1).
Na podstawie Howto: Backup and restore your system! http://ubuntuforums.org/showthread.php?t=35087
Ze względu na wydajność NAS najszybszym sposobem jest wykonanie kopii systemu do archiwum *.tar
Jeśli chcemy ją skompresować zawsze możemy ją zgrać i zrobić to szybciej na znacznie mocniejszym pc.

W moim przypadku kopia ląduje na jednej z partycji. Wykluczone są odpowiednie foldery. W /media mam zamontowane partycje, a w /home/userftp/nas foldery użytkownika ftp z download/upload i podmontowanymi partycjami z danymi.
tar cvpf /media/nas/stuff/nsa310_debian_backup.tar --exclude=/proc/* --exclude=/sys/* --exclude=/run/* --exclude=/tmp/* --exclude=/lost+found/* --exclude=/mnt/* --exclude=/media/* --exclude=/home/userftp/nas/*  /

Takie polecenie pozwala na archwizację tych folderów bez ich głębszej zawartości - zostają puste foldery - nie musimy ich potem tworzyć przez mkdir.
Ponieważ w /media i /home/userftp/nas miałem jednak coś głębiej muszę to odtworzyć.
mkdir /media/nas
mkdir /media/nas/foto
mkdir /media/nas/music
mkdir /media/nas/stuff
mkdir /media/sdb1
mkdir /media/sdc1
mkdir /home/userftp/nas/#download
mkdir /home/userftp/nas/#upload
mkdir /home/userftp/nas/foto-movies
mkdir /home/userftp/nas/music
mkdir /home/userftp/nas/stuff

Jeżeli chcemy zrobić plik z backupem na tej samej partycji co system musimy go również wykluczyć:
tar cvpf nsa310_debian_backup.tar --exclude=/nsa310_debian_backup.tar --exclude=/proc/* --exclude=/sys/* --exclude=/run/* --exclude=/tmp/* --exclude=/lost+found/* --exclude=/mnt/* --exclude=/media/* --exclude=/home/userftp/nas/*  /


Finalnie wrzuciłem wszystkie podfoldery z /media/ i /home/userftp/nas do --exclude i nie muszę nic tworzyć przez mkdir
Archiwum tworzone jest ze wszystkimi folderami z odpowiednio wykluczoną zawartością!

tar cvpf /media/nas/stuff/nsa310_debian_backup.tar --exclude=/proc/* --exclude=/sys/* --exclude=/run/* --exclude=/tmp/* --exclude=/lost+found/* --exclude=/mnt/* --exclude=/media/nas/foto/* --exclude=/media/nas/music/* --exclude=/media/nas/stuff/* --exclude=/media/nas/sdb1/* --exclude=/media/nas/sdc1/* --exclude=/home/userftp/nas/#download/* --exclude=/home/userftp/nas/#upload/* --exclude=/home/userftp/nas/foto-movies/* --exclude=/home/userftp/nas/music/* --exclude=/home/userftp/nas/stuff/* /


Przywracamy system na sda1 używając pendrive z Debianem. Partycja podmontowana w /media/sda1, plik z backupem znajduje się w katalogu głównym pendrive i tam jesteśmy.
tar xvpf nsa310_debian_backup.tar -C /media/sda1


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 15 maja 2016, 08:09 
Offline
Użytkownik

Rejestracja: 21 kwie 2013, 21:16
Posty: 57
Proponuję zapoznać się z opcją --one-file-system dla tar'a, oszczędza sporo pisania :)
Co więcej gzip działa w tar'ze całkiem sprawnie, zwłaszcza, że sporo plików debianowych dobrze się kompresuje (nie ma dużej różnicy w czasie, poza tym zawsze można to wrzucić na screena), np: "tar --one-file-system -czvf /path_to_hdd_backup/nsa310-system-20160515.tgz /" i mamy kopię systemu.


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 31 maja 2016, 08:26 
Offline
Użytkownik
Awatar użytkownika

Rejestracja: 20 lis 2014, 21:35
Posty: 31
Zaktualizowałem swój NSA310S z OFW 4.70 do 4.75.
NAS niby działa, jest dostęp do zasobów na dysku, SSH, ale nie otwiera się strona dostępowa.

Próbowałem restartować serwer web przez polecenie:
/etc/init.d/httpd.sh restart

Ale w odpowiedzi dostaję:
killall: httpd: no process killed
killall: httpd: no process killed
httpd: Syntax error on line 8 of /etc/service_conf/httpd.conf: Cannot load /usr/local/zy-pkgs/lib/libphp5.so into server: libmysqlclient.so.16: cannot open shared object file: No such file or directory


Z dodatkowych pakietów mam włączone tylko:
MetaRepository
PHP-MySQL-phpMyAdmin
Transmission
anyterm
ownCloud
MidnightCommander
ffp


Próbowałem wyłączyć pakiet phpMyAdmin przez polecenie:
cd /usr/local/zy-pkgs/etc/init.d
./PHP-MySQL-phpMyAdmin disable
reboot


I po restarcie pojawia się strona dostępowa NAS, ale po wpisaniu danych logowania nie przechodzi dalej.

W tej sytuacji, jedyne wyjście to chyba powrót do OFW 4.70. Tylko jak to zrobić bez dostępu do strony web?


EDIT:
PROBLEM ROZWIĄZANY.

Zaktualizowałem pakiet PHP-MySQL-phpMyAdmin do wersji 2.0
- bez zmian

Wgrałem firmware 4.70
- bez zmian

Odinstalowałem PHP-MySQL-phpMyAdmin 2.0, zainstalowałem 1.0
- wszystko wróciło do normy :)


Dlaczego firmware 4.75 nie działa?
Tego nigdy się nie dowiem :(


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 5 cze 2016, 00:34 
Offline
Użytkownik

Rejestracja: 5 cze 2016, 00:16
Posty: 3
Panowie spece od NSA310, mam dziwny problem z moim serwerkiem.
Zainstalowany aktualny oryginalny FW, połączenie po LAN 1G (router wdr4300 z Gargoyle, status podłączonych urządzeń w sieci pokazuje 1GE). Jak ściągam jakiś plik bezpośrednio na kompa (również 1GE w tej samej sieci) jestem w stanie nasycić moje łącze internetowe prawie w 99% -ok 11 MB/s) natomiast ściągając ten sam plik na NSA, prędkość pobierania nie przekracza 4,5 MB/s. Samo pobieranie plików (przez pyload) - zużycie procesora 100%
Czy to jest normalne ?
Dam sobie rękę uciąć, że kiedyś nie było takiego problemu (któraś z wcześniejszych wersji FW)
Poza tym jak mogę sprawdzić czy korzystam z jumbo frames ? Mam wrażenie że przy bezpośrednim przesyłaniu plików z kompa do NSA też coś wolno zaczęło chodzić...
Sprawdziłem też połączenie przez FTP - prędkość przesyłu raptem 19,2 MB/s


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 5 cze 2016, 22:45 
Offline
Użytkownik
Awatar użytkownika

Rejestracja: 20 lis 2014, 21:35
Posty: 31
U mnie pobieranie plików z NSA (OFM V4.70) na komputer, to ok. 75 MB/s.
Wysyłanie plików z komputera do NSA, to ok. 45 MB/s
Wyniki podobne przy przesyle przez FTP i SMB.

Urządzenia połączone przez router Asus RT-N15U (OFM).


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 18 cze 2016, 13:54 
Offline
Użytkownik

Rejestracja: 5 cze 2016, 00:16
Posty: 3
A więc co może być przyczyną ?
Poza tym jak wspominałem, Pyload (raptem 2 pliki pobierane jednocześnie) powoduje pełne obciążenie procesora, czy to normalne ? W procesach mam coś takiego:

No. 1 python2.6 96.2 %
No. 2 pdflush 1.0
No. 3 kswapd0 1.0
No. 4 khelper 0.0
No. 5 async/mgr 0.0
No. 6 kblockd/0 0.0
No. 7 scsi_zyxeljob_w 0.0
No. 8 khubd 0.0
No. 9 kmmcd 0.0
No. 10 crypto 0.0


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 28 cze 2016, 22:20 
Offline
Użytkownik

Rejestracja: 15 kwie 2016, 14:00
Posty: 8
Witam,

Mam dwa pytanie:
Czy na nowym uboot da się uruchomić oryginalny OS z nand ?

Czy wiecie dlaczego oryginalny OS może wystartować gdy zrobimy WakeOnLan na jego eth MAC adres (do póki nie braknie prądu) a Debian lub Openwrt/LEDE już nie ?

Ze swojej strony mogę polecić LEDE/Openwrt. Zoptymalizowane pod flash/USB. Fajne GUI/WWW, ogrom pakietów, bardzo lekkie.
U-Boot 2016.05-tld-1 (Jun 12 2016 - 13:59:20 -0700)
ZyXEL NSA310 1-Bay Power Media Server


SoC:   Kirkwood 88F6281_A1
DRAM:  256 MiB
WARNING: Caches not enabled
NAND:  128 MiB
In:    serial
Out:   serial
Err:   serial
Net:   egiga0
PHY reset timed out
MV88E1318 PHY initialized on egiga0
Hit any key to stop autoboot:  0
starting USB...
USB0:   USB EHCI 1.00
scanning bus 0 for devices... 3 USB Device(s) found
       scanning usb for storage devices...
Use USB retry period from the environment: 15 second(s)
1 Storage Device(s) found

Reset IDE: ide_preinit failed
Unknown command 'mmc' - try 'help'

Partition Map for USB device 0  --   Partition Type: DOS

Part    Start Sector    Num Sectors     UUID            Type
  1     2048            6809600         76da3475-01     83
  2     6811648         1052672         76da3475-02     82
loading envs from usb 0 ...
2702 bytes read in 162 ms (15.6 KiB/s)

no IDE devices available
Unknown command 'mmc' - try 'help'
importing envs ...
running scan_disk ...
Scan device usb
device usb 0:1
1 bytes read in 181 ms (0 Bytes/s)
Found bootable drive on usb 0
loading uImage ...
1855188 bytes read in 309 ms (5.7 MiB/s)
loading uInitrd ...
** File not found /boot/uInitrd **
loading DTB /boot/dts/kirkwood-nsa310a.dtb ...
12450 bytes read in 205 ms (58.6 KiB/s)
## Booting kernel from Legacy Image at 00800000 ...
   Image Name:   ARM LEDE Linux-4.4.13
   Created:      2016-06-24  11:56:30 UTC
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    1855124 Bytes = 1.8 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 01c00000
   Booting using the fdt blob at 0x1c00000
   Loading Kernel Image ... OK
   Loading Device Tree to 0fb0c000, end 0fb120a1 ... OK

Starting kernel ...

[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Linux version 4.4.13 (kofec@StacjonarnyLinux) (gcc version 5.3.0 (LEDE GCC 5.3.0 r791) ) #4 Sat Jun 25 12:32:44 UTC 2016
[    0.000000] CPU: Feroceon 88FR131 [56251311] revision 1 (ARMv5TE), cr=0005397f
[    0.000000] CPU: VIVT data cache, VIVT instruction cache
[    0.000000] Machine model: ZyXEL NSA310
[    0.000000] Memory policy: Data cache writeback
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 65024
[    0.000000] Kernel command line: console=ttyS0,115200 root=/dev/sda1 rootdelay=10 mtdparts=orion_nand:0x100000(uboot),0x80000(uboot_env),0x80000(key_store),0x80000(info),0xA00000(etc),0xA00000(kernel_1),0x2FC0000(rootfs1),0xA00000(kernel_2),0x2FC0000(rootfs2)
[    0.000000] PID hash table entries: 1024 (order: 0, 4096 bytes)
[    0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Memory: 254060K/262144K available (3810K kernel code, 130K rwdata, 1408K rodata, 164K init, 192K bss, 8084K reserved, 0K cma-reserved)
[    0.000000] Virtual kernel memory layout:
[    0.000000]     vector  : 0xffff0000 - 0xffff1000   (   4 kB)
[    0.000000]     fixmap  : 0xffc00000 - 0xfff00000   (3072 kB)
[    0.000000]     vmalloc : 0xd0800000 - 0xff800000   ( 752 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xd0000000   ( 256 MB)
[    0.000000]     modules : 0xbf000000 - 0xc0000000   (  16 MB)
[    0.000000]       .text : 0xc0008000 - 0xc0520dc4   (5220 kB)
[    0.000000]       .init : 0xc0521000 - 0xc054a000   ( 164 kB)
[    0.000000]       .data : 0xc054a000 - 0xc056aba0   ( 131 kB)
[    0.000000]        .bss : 0xc056aba0 - 0xc059ae0c   ( 193 kB)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:16 nr_irqs:16 16
[    0.000000] clocksource: orion_clocksource: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 9556302233 ns
[    0.000009] sched_clock: 32 bits at 200MHz, resolution 5ns, wraps every 10737418237ns
[    0.000090] Calibrating delay loop... 1196.85 BogoMIPS (lpj=5984256)
[    0.090083] pid_max: default: 32768 minimum: 301
[    0.090193] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.090211] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.090698] CPU: Testing write buffer coherency: ok
[    0.091055] Setting up static identity map for 0x81e0 - 0x821c
[    0.091372] mvebu-soc-id: MVEBU SoC ID=0x6281, Rev=0x3
[    0.096293] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.096440] pinctrl core: initialized pinctrl subsystem
[    0.097462] NET: Registered protocol family 16
[    0.097834] DMA: preallocated 256 KiB pool for atomic coherent allocations
[    0.098646] cpuidle: using governor ladder
[    0.099024] Feroceon L2: Enabling L2
[    0.099069] Feroceon L2: Cache support initialised.
[    0.115438] SCSI subsystem initialized
[    0.115754] usbcore: registered new interface driver usbfs
[    0.115835] usbcore: registered new interface driver hub
[    0.115900] usbcore: registered new device driver usb
[    0.116819] clocksource: Switched to clocksource orion_clocksource
[    0.117779] NET: Registered protocol family 2
[    0.118309] TCP established hash table entries: 2048 (order: 1, 8192 bytes)
[    0.118344] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
[    0.118373] TCP: Hash tables configured (established 2048 bind 2048)
[    0.118430] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.118452] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.118594] NET: Registered protocol family 1
[    0.119415] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.133321] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.133344] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.135868] io scheduler noop registered
[    0.135889] io scheduler deadline registered (default)
[    0.137086] kirkwood-pinctrl f1010000.pin-controller: registered pinctrl driver
[    0.137673] irq: Cannot allocate irq_descs @ IRQ33, assuming pre-allocated
[    0.138023] irq: Cannot allocate irq_descs @ IRQ65, assuming pre-allocated
[    0.138593] mvebu-pcie mbus:pcie-controller: PCI host bridge to bus 0000:00
[    0.138611] pci_bus 0000:00: root bus resource [io  0x1000-0xfffff]
[    0.138623] pci_bus 0000:00: root bus resource [mem 0xe0000000-0xefffffff]
[    0.138634] pci_bus 0000:00: root bus resource [bus 00-ff]
[    0.138918] PCI: bus0: Fast back to back transfers disabled
[    0.138932] pci 0000:00:01.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    0.139461] PCI: bus1: Fast back to back transfers disabled
[    0.139560] pci 0000:00:01.0: BAR 8: assigned [mem 0xe0000000-0xe00fffff]
[    0.139575] pci 0000:00:01.0: BAR 7: assigned [io  0x10000-0x10fff]
[    0.139593] pci 0000:01:00.0: BAR 6: assigned [mem 0xe0000000-0xe000ffff pref]
[    0.139608] pci 0000:01:00.0: BAR 4: assigned [mem 0xe0010000-0xe0013fff 64bit pref]
[    0.139630] pci 0000:01:00.0: BAR 2: assigned [mem 0xe0014000-0xe0014fff 64bit pref]
[    0.139649] pci 0000:01:00.0: BAR 0: assigned [io  0x10000-0x100ff]
[    0.139662] pci 0000:00:01.0: PCI bridge to [bus 01]
[    0.139673] pci 0000:00:01.0:   bridge window [io  0x10000-0x10fff]
[    0.139686] pci 0000:00:01.0:   bridge window [mem 0xe0000000-0xe00fffff]
[    0.170255] Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
[    0.171293] console [ttyS0] disabled
[    0.171365] f1012000.serial: ttyS0 at MMIO 0xf1012000 (irq = 26, base_baud = 12500000) is a 16550A
[    0.719063] console [ttyS0] enabled
[    0.723845] nand: device found, Manufacturer ID: 0xec, Chip ID: 0xf1
[    0.730261] nand: Samsung NAND 128MiB 3,3V 8-bit
[    0.734895] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[    0.742520] Scanning device for bad blocks
[    0.779972] Bad eraseblock 348 at 0x000002b80000
[    0.785227] Bad eraseblock 355 at 0x000002c60000
[    0.820998] Bad eraseblock 681 at 0x000005520000
[    0.827510] Bad eraseblock 701 at 0x0000057a0000
[    0.840328] Bad eraseblock 787 at 0x000006260000
[    0.858315] Bad eraseblock 927 at 0x0000073e0000
[    0.869129] Bad eraseblock 992 at 0x000007c00000
[    0.876756] 9 cmdlinepart partitions found on MTD device orion_nand
[    0.883062] Creating 9 MTD partitions on "orion_nand":
[    0.888246] 0x000000000000-0x000000100000 : "uboot"
[    0.894670] 0x000000100000-0x000000180000 : "uboot_env"
[    0.900999] 0x000000180000-0x000000200000 : "key_store"
[    0.907302] 0x000000200000-0x000000280000 : "info"
[    0.913148] 0x000000280000-0x000000c80000 : "etc"
[    0.918967] 0x000000c80000-0x000001680000 : "kernel_1"
[    0.925190] 0x000001680000-0x000004640000 : "rootfs1"
[    0.931445] 0x000004640000-0x000005040000 : "kernel_2"
[    0.937719] 0x000005040000-0x000008000000 : "rootfs2"
[    0.944548] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.951143] ehci-pci: EHCI PCI platform driver
[    0.955679] ehci-platform: EHCI generic platform driver
[    0.961082] ehci-orion: EHCI orion driver
[    0.965280] orion-ehci f1050000.ehci: EHCI Host Controller
[    0.970850] orion-ehci f1050000.ehci: new USB bus registered, assigned bus number 1
[    0.978683] orion-ehci f1050000.ehci: irq 30, io mem 0xf1050000
[    0.996836] orion-ehci f1050000.ehci: USB 2.0 started, EHCI 1.00
[    1.003576] hub 1-0:1.0: USB hub found
[    1.007549] hub 1-0:1.0: 1 port detected
[    1.011951] usbcore: registered new interface driver usb-storage
[    1.020513] NET: Registered protocol family 10
[    1.027910] NET: Registered protocol family 17
[    1.032430] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[    1.045127] 8021q: 802.1Q VLAN Support v1.8
[    1.051738] hctosys: unable to open rtc device (rtc0)
[    1.058492] Waiting 10 sec before mounting root device...
[    1.326832] usb 1-1: new high-speed USB device number 2 using orion-ehci
[    1.479096] hub 1-1:1.0: USB hub found
[    1.483199] hub 1-1:1.0: 4 ports detected
[    1.766830] usb 1-1.3: new high-speed USB device number 3 using orion-ehci
[    1.885415] usb-storage 1-1.3:1.0: USB Mass Storage device detected
[    1.892059] scsi host0: usb-storage 1-1.3:1.0
[    2.888906] scsi 0:0:0:0: Direct-Access     Generic  Flash Disk       8.07 PQ: 0 ANSI: 4
[    2.899104] sd 0:0:0:0: [sda] 7864320 512-byte logical blocks: (4.03 GB/3.75 GiB)
[    2.907470] sd 0:0:0:0: [sda] Write Protect is off
[    2.913093] sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[    2.930005]  sda: sda1 sda2
[    2.936219] sd 0:0:0:0: [sda] Attached SCSI removable disk
[   11.068222] EXT4-fs (sda1): mounting ext3 file system using the ext4 subsystem
[   11.090675] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[   11.098444] VFS: Mounted root (ext3 filesystem) readonly on device 8:1.
[   11.105585] Freeing unused kernel memory: 164K (c0521000 - c054a000)
[   11.431165] init: Console is alive
[   11.805488] sata_mv f1080000.sata: slots 32 ports 2
[   11.813640] scsi host1: sata_mv
[   11.817363] scsi host2: sata_mv
[   11.820740] ata1: SATA max UDMA/133 irq 32
[   11.824870] ata2: SATA max UDMA/133 irq 32
[   12.176839] ata1: SATA link down (SStatus 0 SControl F300)
[   12.526835] ata2: SATA link down (SStatus 0 SControl F300)
[   12.534904] init: - preinit -
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[   15.728456] mount_root: mounting /dev/root
[   15.740364] EXT4-fs (sda1): re-mounted. Opts: (null)
[   15.745511] mount_root: loading kmods from internal overlay
[   15.949395] block: attempting to load /etc/config/fstab
[   15.962287] block: extroot: not configured
[   15.972612] procd: - early -
[   16.233200] random: jshn urandom read with 90 bits of entropy available
[   17.055549] procd: - ubus -
[   17.132449] procd: - init -
Please press Enter to activate this console.
[   17.325655] zram: Added device: zram0
[   17.340750] ntfs: driver 2.1.32 [Flags: R/O MODULE].
[   17.365119] tun: Universal TUN/TAP device driver, 1.6
[   17.370252] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[   17.408240] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   17.430883] i2c /dev entries driver
[   17.450897] Loading modules backported from Linux version wt-2016-05-12-0-g7a54796
[   17.458538] Backport generated by backports.git backports-20160216-0-ge3c56e4
[   17.468619] ip_tables: (C) 2000-2006 Netfilter Core Team
[   17.479954] nf_conntrack version 0.5.0 (3972 buckets, 15888 max)
[   17.497880] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[   17.503522] pci 0000:00:01.0: enabling device (0140 -> 0143)
[   17.509266] r8169 0000:01:00.0: enabling device (0140 -> 0143)
[   17.516104] r8169 0000:01:00.0 eth0: RTL8168d/8111d at 0xd0ac0000, 00:00:00:00:00:30, XID 083000c0 IRQ 83
[   17.525751] r8169 0000:01:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[   17.548724] rtc-mv f1010300.rtc: rtc core: registered f1010300.rtc as rtc0
[   17.556767] random: nonblocking pool is initialized
[   17.597707] xt_time: kernel timezone is -0000
[   19.294450] zram0: detected capacity change from 0 to 130023424
[   19.365897] Adding 126972k swap on /dev/zram0.  Priority:-1 extents:1 across:126972k SS
[   21.074077] r8169 0000:01:00.0 eth0: link down
[   21.078856] r8169 0000:01:00.0 eth0: link down
[   21.085228] device eth0 entered promiscuous mode
[   21.091277] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   23.183031] r8169 0000:01:00.0 eth0: link up
[   23.188129] br-lan: port 1(eth0) entered forwarding state
[   23.193585] br-lan: port 1(eth0) entered forwarding state
[   23.200103] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   25.186831] br-lan: port 1(eth0) entered forwarding state



BusyBox v1.24.2 () built-in shell (ash)

     _________
    /        /\      _    ___ ___  ___
   /  LE    /  \    | |  | __|   \| __|
  /    DE  /    \   | |__| _|| |) | _|
 /________/  LE  \  |____|___|___/|___|                      lede-project.org
 \        \   DE /
  \    LE  \    /  -----------------------------------------------------------
   \  DE    \  /    Reboot (HEAD, r791)
    \________\/    -----------------------------------------------------------


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 29 cze 2016, 13:58 
Offline
Użytkownik

Rejestracja: 14 cze 2013, 10:24
Posty: 21
Z tego zrodla zainstalowales?
https://downloads.lede-project.org/snap ... d/generic/
Jesli tak to ktory?


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 29 cze 2016, 14:50 
Offline
Użytkownik

Rejestracja: 15 kwie 2016, 14:00
Posty: 8
I tak i nie. Z tego źródła ale musiałem dodać moduł od karty sieciowej(r8169 Gigabit Ethernet driver) i sterownik LM85 w moim przypadku. Wiec przekompilowalem sobie sam.

https://github.com/lede-project/source

A instalujesz tak jak Debiana z tym ze rozpakowujesz sobie na USB:
lede-kirkwood-generic-rootfs.tar.gz

i w folderze boot dodajesz folder dts i wrzucasz tam odpowiedni plik.


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 8 lip 2016, 14:07 
Offline
Użytkownik

Rejestracja: 8 lut 2016, 22:58
Posty: 1
Witam czy na orginalnym oprogramowaniu można do pyload dodać serwis catshare.net
Witam ponownie prosze o pomoc jak zalogować sie do nas przez putty .bez waszej pomocy koledzy nie dam rady nic zrobić
pozdrawiam

Witam i dzięki color1, powoli zaczyna być wszystko jasne. Całkiem niezły ten sprzęt


Ostatnio zmieniony 13 lip 2016, 19:36 przez jurek341@wp.pl, łącznie zmieniany 1 raz

Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 12 lip 2016, 15:43 
Offline
Użytkownik

Rejestracja: 5 cze 2016, 00:16
Posty: 3
http://zyxel.nas-central.org/wiki/Telnet_backdoor


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 12 wrz 2016, 11:12 
Offline
Użytkownik

Rejestracja: 25 paź 2011, 12:43
Posty: 308
osa pisze:
[b]Edit 5
Edit 4: Automatyczna instalacja Debiana

Pobieramy 2 archiwa :
wersja aktualna ... i linux.tgz - poprawiony link - ten link nie dziala. Udostepnisz?


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
 Tytuł: Re: ZyXEL NSA310
Post: 12 wrz 2016, 11:21 
Offline
Użytkownik

Rejestracja: 6 maja 2010, 21:55
Posty: 523
To jest bardzo stary debian squeeze jak chcesz, odszukam gdzieś archiwum. Jedyną zaletą był tryb recovery.
Jakbyś chciał nowszego to tu jest wheezy viewtopic.php?f=19&t=3332&hilit=nsa320
Ole on też jest w miarę stary. Jak masz kabelek serwisowy zajrzyj do boghi-ego na http://forum.doozan.com/read.php?2,12096
Koleś robi dobrą robotę


Na górę
 Wyświetl profil  
Odpowiedz z cytatem  
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat Odpowiedz w temacie  [ Posty: 1884 ]  Przejdź na stronę Poprzednia  1 ... 88, 89, 90, 91, 92, 93, 94, 95  Następna

Strefa czasowa UTC+1godz. [letni]


Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 2 gości


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów

Szukaj:
Przejdź do:  
designed by digi-led.pl
...Copyright © 2010-2013, Ekipa openrouter.info